Particle usb drivers windows 7 professional for Mesh Devices


#1

Trying to communicate between xenon and the CLI in listening mode or DFU mode, Windows 7 professional rejects the spark device driver. It allowed me to install the driver momentarily after warning me not to install it, then Windows 7 somehow removed it…even from the list to select manually. I don’t think the driver has an acceptable signature or something like this. I could not decide which USB serial (CDC driver to install which would work. I know this is a known problem. Should be a solid fix somewhere. I think support guy scarf knows a fix.


#2

There are two different drivers, one for USB serial and one for USB DFU.

There is no working driver for DFU mode for Windows 7, 64-bit. You’ll need to use a different computer if you need to use DFU mode. 32-bit Windows 7 is fine, and either 32 or 64-bit is fine for 8.0 and later.

Also note that a factory new mesh device (Argon, Boron, or Xenon) does not support USB serial mode. It can only be programmed in DFU mode or Bluetooth from the mobile app until upgraded to 0.8.0-rc.25, then it will work with USB serial.

This document should have what you need to troubleshoot the serial driver with Windows 7.

If you have upgraded your Xenon to 0.8.0-rc.25 make sure you put it in listening mode (blinking dark blue) if you need to troubleshoot USB serial mode. If you let it run Tinker, the USB serial won’t show up.


#3

Thank you rickkas7. I am running windows 7, 32 bit. I will try to find that document.


#4

Hi rickkas7,
I printed out your particle_notes and followed your clear instructions, including “Removing old drivers,” showing hidden drivers, and deleting the old one (Xenon CDC Mode) and then, closing the device manager and re-plugging in the serial cable attached to my xenon. Windows then reinstalled the Xenon CDC Mode driver, but when I went to the CLI, and asked it to list the serial devices, here is the result:
C:>particle serial list
No devices available via serial

The Xenon CDC Mode driver does not seem to work. I will try the other options you described later in your Particle_notes article, but I don’t hold much hope for them. I spent hours on this last evening.

C:>


#5

Hi Rickkas7,

Briefly, Windows allowed me to install the particle/spark driver when I ignored its warning not to install that driver, and while it was installed, I found out the following information about my Xenon. (Shortly after this, windows uninstalled the spark driver and I have not been able to get it re-installed.
C:\Users\Tom>particle serial inspect
Platform: 14
Modules
Bootloader module #0 - version 214, main location, 49152 bytes max size
Integrity: PASS
Address Range: PASS
Platform: PASS
Dependencies: PASS
System module #1 - version 324, main location, 671744 bytes max size
Integrity: PASS
Address Range: PASS
Platform: PASS
Dependencies: PASS
Bootloader module #0 - version 101
undefined module #0 - version 0
User module #1 - version 5, main location, 131072 bytes max size
UUID: A32EA2ECB44FFD921FA37C0EE7752F3A659B5C82539B7C79023834AF8F38C8BC
Integrity: PASS
Address Range: PASS
Platform: PASS
Dependencies: PASS
System module #1 - version 312
undefined module #0 - version 0
empty - factory location, 131072 bytes max size


#6

Hi Rickkas7,
I believe I followed your instructions in your article particle_notes, and was never able to get anything but the Xenon CDC Mode driver to load. It has a yellow flag on it, and apparently no driver is really installed for the xenon. Therefore I cannot use the CLI to do a particle serial list. It finds no devices. I cannot get my 32 bit windows 7 pc to install usable drivers for the xenon. The instructions in your article may work for the photon and electron, but they don’t seem to be working for me on the xenon.


#7

@rickkas7, I’m in the same boat here. I have the Xenon on an Ethernet Featherwing attached to my PC and it is the gateway for my 3-device mesh network. On my corporate workstation, I have Windows 7 64-Bit. I ran the latest ParticleCLISetup.exe and it was unable to fix the warning triangle on the “Xenon CDC Mode” device. I am unable to see the Xenon via the CLI. A particle serial list returns no devices. Following your notes, the driver you point to in the git repo doesn’t list Mesh devices as an option… just Electron/Photon/P1.

image

image

I came across this post where @ScruffR recommending using zadig to install the libusbk driver. I installed zadig and chose the libusbk driver for the Xenon CDC Mode object… which makes the Xenon now show under “LibusbK Usb Devices” in device manger without a warning triangle. But a particle serial list does not show any devices. Also to note, after I did the zadig thing, I put the Xenon into listening mode (blinking dark blue) and there was no change to the device manager… but it was now under Libusbk devices if that matters.

image

I do not want DFU mode, I simply want to run the particle serial monitor to view debugging output. Is there a step I’m missing? You mention that Win 7 64-bit is not supported for DFU mode… but what about simple serial output monitoring?


How to output to Serial Port Monitor?
#8

libusbK drivers are only for the device in DFU Mode.

You could try zadig to install USB Serial (CDC) driver for Listening Mode, although the Particle drivers should work.


#9

@ScruffR… And that fixed the issue. I used zadig to update to the USB Serial (CDC) and now it shows via CLI. Thanks!