New Windows Drivers and general availability of mesh and USB CLI commands


#1

Hi all,

As of today, the Windows CLI Installer includes a revamped drivers installer. To get the new drivers, download and install with the following link (it works even if you previously had installed the CLI):

Windows CLI Installer

If you need to install the drivers only, you can also download and run the standalone Windows Drivers Installer.

The drivers support Windows 7, 8 and 10 and all Particle hardware (Gen 1, 2 and 3) with any version of Device OS. For best support, update to the latest Device OS for the device you are working on.

The new drivers provide support for the second USB serial port USBSerial1 which you can use in your firmware the same way you’d use Serial but the data goes to a separate serial port.

The new drivers also provide support for the particle usb and particle mesh CLI commands on Windows. For details of these commands, see this post:

These commands allow putting the device in DFU mode or listening as well as setting up mesh networks from the command line.

With the release of the new Windows drivers, the particle usb and particle mesh commands are now generally available (i.e. no longer in beta) for Windows, Mac and Linux. Let us know if you run into any issues with these commands after installing the new drivers.


Particle Tools Changelog
#2

Hi there I updated the CLI and tried some of the commands

on Win10 machine
Electrons
2x Electrons via USB

particle usb list
Unable to open USB device: LIBUSB_ERROR_NOT_SUPPORTED

particle usb dfu --all
Unable to open USB device: LIBUSB_ERROR_NOT_SUPPORTED

particle update

Your device is ready for a system update.
This process should take about 30 seconds. Here it goes!

! System firmware update successfully completed!

Your device should now restart automatically.

I have rebooted the machine and the Electrons, and unplugged the USB to make sure.

The serial ports still work under Teraterm although the name for the serial port has disappeared (it used to say Electron.
image


Electron won't connect to GSM and unable to put in program mode
#3

Can you run the standalone driver installer, making sure to click the Uninstall previous drivers checkbox and try again?


#4

i had the same usb error after running particleclisetup.exe. after running particle_drivers.exe and selecting uninstall current drivers the particle usb list command worked correctly.


#5

Just a note for others, if you use Kaspersky IS and/or AV, you will probably have to disable it or set it to exclude paexec.exe and PAEXEC_*.exe, or it will actively try and disinfect the machine as the installer is running.

It took a couple of goes before I got through the chaos, but successfully installed the new drivers.


#6

Thanks - that fixed it.