Xenon stuck flashing white

I’d recently decided to do some real world testing of the effective ranges of the Bluetooth mesh so I decided to break out the devices I got at Spectra and write some custom ping functions to use. Flashing my updates to my gateway I noticed that it would flash a red SOS before restarting and eventually breathing cyan normally. I try reverting the code changes I had made but the default Gateway ping is no longer working and the Xenon is still flashing red when I update it.
Figuring numerous updates had been done since Spectra seeing as they are now shipping the mesh devices, and noticing a new Mesh network tab on the console website, I decided to un-claim both the gateway and badge figuring re-adding them would help sort out whatever was going on (I now realize this probably was a mistake).
I go about claiming the gateway first as I’ll need to setup a new mesh network and I notice that the claim process now updates the devices firmware to the latest version (0.8.0-rc.25). Having finished setting up the gateway I move on to claim the badge Xenon. Setup proceeds normally until it gets to the firmware update step. The Xenon starts blinking magenta as it had on the gateway but I get a popup on my phone immediately notifying me that the Bluetooth connection had been lost and to put the Xenon back into listening mode. Trying this a few times and even completely restarting the claiming process but coming to the same roadblock I come to the conclusion that since the device is doing a firmware update it needs a “permanent” internet connection in order to download and update everything correctly, as I had gotten the same message with the gateway but putting it back into listening mode and hitting retry on the app successfully updated the firmware.
I then go about taking the Xenons out of the badge and and Ethernet featherwing, and placing the former badge xenon into the Ethernet wing. I then tried to claim the xenon normally and got as far as the firmware update when I got a similar message as I had been getting before, only this time the Xenon was flashing white instead of magenta. I tried getting it back into setup mode but that does not appear to be possible now. I then tried to use the doctor/upgrade tools in the latest CLI (1.35.2) but evfen though I could get the Xenon into DFU mode I got the following from the CLI:

!!! I was unable to detect any devices in DFU mode…

That’s where I’m at right now and I’m kinda stumped as to what to try now.

Try resetting your device via press/hold MODE for 10+ seconds till the LED blinks rapid blue.
After that press/hold MODE and tap RESET and keep holding MODE till the LED goes white (after magenta and yellow) and eventually starts rapid white blinking.
For safe measure you can then put the device in DFU Mode and flash a dummy rc.25 application (e.g. Tinker)
With the device prepared that way try running through the setup process again.

BTW, if you are using Windows your DFU not found message might be cured by installing the libusbK drivers via zadig.

Resetting the device didn’t work, held the mode button down for at lest 30 seconds but the LED stayed solid white.

You were right about why the Xenon wasn’t showing up in DFU mode, and flashing tinker did indeed update the device firmware to rc25 allowing setup to complete. Thanks for the tip.

Now I just need to figure out how to compile the Spectra code in rc25.

That might be due to currently running code. First going into Safe Mode does often help removing that.

re: driver – does that apply to Windows 10?

NVM it does apply to Win 10.