Particle status led doesnt flash

I presume if the status led doesn’t flash, i fried my micro controller.

sorry if there was a resource about this already i searched but couldn’t find anything.

Let’s not jump to conclusions that quickly.
What exactly doesn’t it do anymore, and perhaps more importantly, what does it still do (anything at all)?
At the risk of sounding stupid, have you tried plugging it out&in again, possibly with a different power supply/cable?
What was it doing when it stopped working? What circuitry had you attached at the time?
Have you tried safe mode yet? What does it do, if anything?
Have you tried DFU mode yet? What does it do, if anything?

Should have included more information. i plugged in a 4xAA battery pack connected the postive to the VIN and the Negative to the GND since then the led status indicator stopped blinking. i am unable to connect to it from my nodejs app that i wrote.

Seeing as the issue started when you changed power sources…

Could it be that the batteries are (almost) empty? They then can supply sufficient voltage, thus your device won’t boot. For debugging sake, please use a decent usb power supply to test.

And what about these?

In addition, if your batteries are near dead, you might put your voltage regulator in danger of blowing.

Powering off batteries without monitoring the status of them is dangerous for your device.

1 Like

I have tried using the usb power. when i do the servo’s set themselves to the default state. since the LED Status indicator doesn’t turn on i have no idea if i have entered safe mode or not. i have tried to enter it but not sure if it makes a difference. is there a way for me to ping the micro-controller over usb using telnet for example to see if it is still alive

I am aware that i was doing dangerous stuff, so not sure if the devices is fried :smile:

You could always try to power your Photon via 3V3 off a relyable 3.3V source, but be sure to have all other components detached.
Usually if you have an issue like this, I’d not expect to have your device still connected to servos - as your previous post indicates :wink:

Next thing that could also cause unlit LEDs is that your code takes control of the LED via RGB.control(true); or you previously set RGB.brightness(0), since this setting will persist across reboots and even in Safe Mode (I think :blush:)

In addition to what @ScruffR said,

Not sure how you wired those up, but they might be drawing more power than your supply can deliver. Especially if you’re powering them through the Photon, things might get problematic.
Detach it from all external circuitery, and hook it up to a decent power supply. Then give Safe mode another try.

Hey @Moors7 and @billybonks, I am currently experiencing the same issue. In my situation the pin D7 led is lit but the status led is not. Similar to this thread.

I reached this state by connecting VIN to a 5V power supply (no regulator in between). I have disconnected the Photon from everything and now if I plug the Photon into a USB port on my laptop I just get the pin D7 light, no status light (and shows as not connected in Dashboard).