Particle electron slow white flash then slow blue flash - then faster blue flash

Hi Particles.
I have had an electron sitting idle for a while using ver: 5.5 firmware when I turned it on. Really long time until it connected to 3G (I’m in Australia) and then exhibited some odd behaviour locking up randomly, particularly when I triggered a Particle.function (almost identical to the “light an LED” example). So I set about upgrading the firmware following the upgrade path to 5.5, 6.0, 7.0 the 1.2.1 - as recommended.
Same odd behaviour with functions occurred - and I reset the SIM card. After that the unit (on turn on) breathes white for a few seconds, then goes to a slow (breathing) blue - then a blue flash that is more rapid. I cleaned the SIM, re-inserted (orientation is correct) but same problem,
Any ideas?

I’d reflash Tinker to know the application firmware is not contributing to any confusion.
Also have a check of the device OS integrity via particle serial inspect.
You can post this and also a 30sec video of the RGB pattern for us to see what’s going on exactly.

Hi @ScruffR - I’m unsure how to reflash Tinker, and couldn’t find anything here. If there’s a link - I’m happy to do it. But I think the problem is worse than expected. I am unable to get the device into listen mode to hook up to the CLI and run particle serial inspect. I will upload the sequence when I figure out how to make the video less than 60Mb. The sequence is short red flash - white “breathing” blue slow, similar to breathing - then blue about 500ms flash

Put the device in DFU Mode and run
particle flash --usb tinker -v

You can upload the video to YouTube (or similar platform) and post a link.

Seems I’ve had success with tinker - but no other improvement
I’ll get that video up soonest

Hi @ScruffR and thanks again for your help - I really owe you lunch if you ever come to Australia.
OK, I think I have some progress on what may have caused the problem. I believe it my have been a cheap power supply that was rated to 2 amps but maybe could not handle the sudden demand of the Electron (and a couple of other small power demand components on a circuit board). I have a second Electron, which when plugged into the circuit took ages to connect to the network (cyan breathing) then started to behave erratically when I actioned some remote Particle.function (s) - and getting nervous I killed the power. I tried again with the (LiPo) battery attached and everything behaved as I’d hoped. I ran it overnight and it remained solid.
My program includes the standard code for operation without a battery, being PMIC _pmic; (declared at top of code) and _pmic.disableCharging(); in Setup. Though this clearly does not affect battery as additional supply if connected.
So my next step was to change the power supply to an industrial grade Switch Mode 5 volt 2.2 A model (this one https://au.rs-online.com/web/p/embedded-switch-mode-power-supplies-smps/6447039/) and removed the (LiPo) battery. Everything continued to work as intended without the (LiPo) battery attached and I’m feeling pretty relieved.
But on to my broken Electron. The Particle troubleshooting guide suggests the main problem blinking blue is a bad SIM connection – but I don’t think this is the case. I removed and cleaned the SIM and inspected it under a magnifying glass – it had score marks from the connectors in the right places and when reinstalled I used a plastic clamp to apply some pressure – the result as the same fail sequence, which I’ve uploaded to YouTube here https://youtu.be/AHgDMS6Zoos please note, in this video I used a battery and the red flash I got using a 5 volt supply to VIN did not occur.
Please note that regarding the CLI – I was able to flash Tinker in DFU mode but am otherwise unable to communicate with the Electron by serial.

update + 3 hours: I ran DFU mode and successfully updated the firmware via particle update - then reinstalled Tinker. No change. I then tried to interface by serial (out of DFU mode) in the brief period between white breathing and rapid blue flash - which is a blue breathing phase similar to listening mode using particle serial inspect - but no joy. messages were as follows:

particle serial inspect
The serialport dependency is missing or invalid.
! Please reinstall: https://docs.particle.io/tutorials/developer-tools/cli/#installing

XXXXXXX\particle-cli\node_modules@serialport\bindings\lib\binding\node-v72-win32-x64\bindings.node

In order to get CLI working again you can remove it via Programs and Features in Control Panel and then reinstall it via the latest Windows installer.

Would be good to have a recent log of particle serial inspect for support to.
I think you should file a support ticket at support.particle.io for that device.