Particle Dev Compiling but not Flashing

I’m having intermittent problems with Particle Dev where it compiles my code, returning “success” but does not flash the Photon. It will flash small programs pretty consistently, but larger ones will work one time, but not the next. I have the device selected. The firmware is 0.6.1 if that matters.

Suggestions would be appreciated.

Does it make any difference if you place your device in Safe Mode beforehand?

No. Putting it in safe mode doesn’t help. It looks like it is not trying to contact the device at all. Almost as if the compile failed in some way, but still shows Success!


For me sometimes this is normal. I just keep trying and it always ends up working as long as the Photon is breathing cyan color.

Sometimes the internet slows down and is to blame.

Overall Particle DEV for me has been very reliable.

It’s nice to know that someone else as the same problem. But I just tried 4 times without success. It’s kind of a long compile, so the development cycle has gotten real slow.

Same here, I’m compiling a large project and its taking much longer than normal and sometimes it does not flash a Photon but trying another time usually works.

I am experiencing similar behavior. The compilation web service is working (returning success) but the following requests to download the generated binary (the output of the compilation) is returning HTTP status 500.

So the build phase is probably technically working but the obtaining of the firmware used to flash the device is then failing.

I am seeing this in SpeckCode too. Hopefuly it is a short term issue.

It’s been compiling and flashing just fine for me almost 100% over the last few days to be fair on my end.

I’m flashing a Photon.

This has got me dead in the water. Small programs flash just fine, but the larger one I am working on has failed 10 of 10 attempts. I uninstalled and reinstalled Particle Dev on my Windows 10 box. No help. I installed Particle Dev on my Mac, it seems to work about 1 time in 3. Arrgh!
– Doug

How big is your program?

Usually in DEV after it does compile it will save the BIN file in file directory and then I can just hit compile and flash again and it will instantly flash my device. At least it has worked that way quite a few times for me.

I don’t personally like using Particle CLI but others do and it does allow you to flash your devices over USB instead of Wifi.

I know an older Dev used to save the firmware in the project directory. The current one doesn’t seem to do that. Yeah, I thought about flashing with the CLI, but couldn’t find the .bin.
– Doug

Actually, I’m using DEV right now and if I click the Cloud Compile and check for errors button and then if my code compiles successfuly it drops the BIN file into the same folder directory that my code files are in that I’m working on in DEV.

I can then hit flash next and it flashes instantly. If you do not hit the flash button then you could take the bin file and upload it using CLI over USB.

I’m using the latest version of Particle DEV off the website.

You’re right. If the compile really succeeds, there is a BIN file. So when I having the problem with the Particle not being flashed, there is no BIN file. So I’d guess it is not being generated in the cloud or DEV is having trouble downloading it.
– Doug