Particle Dev - not flashing code

I’ve been using Particle Dev for quite some time and all of a sudden it will no longer flash the firmware to my device. The device has been selected. There’s an orange message at the bottom of the screen indicating “build didn’t produce binary Error: Command…” If I click on it, is simply shows a window indicating “there were no compile errors.”

With all this said, I was making program changes (many) today and compiling without the device plugged powered up (it was at a different location). Do I need to do something to re-engage flashing and getting the compiler to produce a binary to flash?

Can you try particle compile photon . firmware.bin from within the project folder?
Could it be that your project exceeds the 120K?

Or other suggestions that can be found via forums search “didn’t produce binary

I experienced the same thing. Particle Dev doesn’t appear to be as sophisticated as the command line compile in detecting errors. The command line will generate error messages that Particle Dev won’t. Give it a try, then once the error is identified go back to Particle Dev.

So…it was likely a rookie mistake on my part (I’m really having too many of these! :wink: ). I had created another version of the main program and it was in the same folder with the .ino suffix. I had incorrectly assumed that it would compile the file that was open in the editor. Once I removed the earlier version of the program, everything worked fine.

By the way, I saw the errors when I ran the compile from the command line and realized my mistake.


1 Like