Particle cli stopped working Win8

It was working just this morning.
Is this a side effect of the new release? I found this in AppData/Local/particle/error.log

2017/01/23 13:15:55 Updating CLI…
2017/01/23 13:17:37 done. Updated 1 package.

Now when I run particle I get no output.

1 Like

Thanks for reporting. @jvanier are you able to take a look at this?

I’ll take a look.

I ended up uninstalling the CLI and reinstalling.

reinstalling via the windows installer linked in the ref page did not fix it

reinstalling via node.js worked:
npm install -g particle-cli

I release a new revision of the CLI package that fixes this issue. If you installed the CLI through the Windows installer you can force an update with particle update-cli (this won’t work if installed through npm).

[Edit: clarified what I meant]


Not sure what you mean - the CLI does not recognize that command: particle update-cli
I updated to 1.19.1 via npm install.

Ah. Your clarification explains a bit. I lost the particle update-cli command when I reinstalled via npm.

I can only confirm the same issue on Win10. Yesterday out of a sudden particle.exe refused to work. particle update-cli helped.

1 Like