SOLVED: Particle CLI latest update broke me

I was informed at the CLI on Win10 today to go get the latest update with the npm command. Which I did. And now I’m broken. Getting an error on loader.js: 582, Error: Cannot find module. I’ve done npm uninstall and install again, no luck. Uninstall.exe, then downloaded the windows CLI installer and installed - still no luck. There was a python error at one point with the npm install, so I downloaded and installed latest version of Python, that error went away but there’s another error during npm install.

Why can’t this just work? seems so fragile… I’m irritated.

Here’s the npm install error messages if anyone has any ideas would greatly appreciate it!

SOLVED: Reinstalled Node, was at 10.13 LTS, now on 10.15.1, not sure if the version had any impact but it’s working again.

CLI on Windows should bring its own version of node.
There recently was a post (in regards to a Particle Workbench update) that suggested to uninstall CLI via Control Panel and then reinstall with the most recent Windows CLI Installer.