Particle-cli incompatible with newest Node (npm method)


#1

I tried to run a command on the CLI after not using it for a couple of months. It said that a new version was available and also please reinstall CLI again. So I tried that but I get errors. See this link for the terminal output. As you can see, I updated to the newest NPM as well. Why would this happen to me?

https://pastebin.com/jDnLkueP

Mac OS 10.14.3


#2

What CLI command did you use to update it? particle update-cli?
Latest version is 1.42.0
I am on mac OS 10.14.5 and I can’t reproduce the issue


#3

I ran npm install -g particle-cli


#4

To update via npm you’d rather use npm update -g particle-cli, but with a fairly recent version you should be abelt to use particle update-cli as @armor mentioned already.


#5

completely removed node. Manually removed node-installed packages. Reinstalled the most recent version of node. Ran npm install -g particle-cli. Still same errors. Is particle-cli not compatible with node 12.6?

My output (pretty much same as before): https://pastebin.com/Agsh0xDJ


#6

Downgraded Node to 10.16. It installs fine now. Please add support for the newest Node.