Particle CLI from other drives?

I have been trying to use Particle Cli to create a library structure and add a dependency. On windows 10, I have all my apps installed on the C: drive but I keep all my data on my F: drive. If I run particle library list from anywhere on C: everything works fine but if I run the same command from anywhere on F: I get the following error:

HTTP error 400 from - The access token was not found

Is there something I need to do in order to get this to run on other drives?

Have you logged in to particle-cli with $ particle cloud login?

1 Like

Wow. No. :astonished:

I didn’t realize you needed to do that from each local drive you wanted to run it from… I thought once you were logged in on a machine you were logged in everywhere.

Works fine now.



This might be an issue of storing relative paths for CLI.
May worth a GitHub issue, but first need to establish under what circumstances this happens - doesn’t happen for me in Win 8.1 Pro 64bit.
Have to test on some other machines.

Can’t reproduce it on any of my machines, so it might be a local issue.