Particle build is failing to compile ( verify button ) for that last ~2 hours , but worked earlier

I tried to reboot my system , log in / log out. Try different browsers , clear the particle build settings cache.

This is on a Win 10 PC

This is the sequence of messages after I click on ✓ button

Compiling Code …
The Server failed to service the request on time , Please try again
Ready

What deviceOS and device type are you compiling against, and where from?

Xenon 0.8.0-rc.27

Devices are connected to my win10 USB

That helps. Where are you physically based, so location can be checked?

Redmond WA , in the greater Seattle area

Interesting I only get the below error message for one specific Particle App

“The Server failed to service the request on time , Please try again”

Several other apps actually compile.

Why would the sever not be available for a specific app ?

You mean firmware, right?
If so, there are multiple possibilities.

  • The resulting binary may be too big
  • Some combination of libraries or compiler directives trip up the preprocessor/compiler
  • The project was for a target < 0.5.2 and the file structure is incompatible

If you could provide a SHARE THIS REVISION link we might be able to check for ourselves.

Any chance you could check the developer console of the browser for errors? (Right click - inspect)

I see , the message "server filed the service request on time " is a generic error message about some kind of build problem , not specific to indicating server availability error.

These error message could be a bit more granular or specific.

I copied code to a new partial app , an all works again.