Cloud Compiling is Failing (ECCONNRESET)

I am getting:

Compile failed. Exiting.
{ [Error: socket hang up] code: ‘ECONNRESET’ }

Not sure if this is my end or yours (I’m on satellite internet and it’s raining… :unamused:) I’ll be on a better connection later today and will try again.
Compile has failed in Particle Dev and CLI

Any help is apprectiated.


I am also unable to flash on Particle dev. It just says compiling in the cloud and then disappears. Subsequent attempts to compile does not show anything until Particle Dev is restarted.

Same here can’t verify / flash. And i’m just getting started, Great start :smiley:

Can someone confirm if they can compile please.

The status page shows the compile service as operational

Currently unable to compile or verify, it just sits there for a bit and then presents an error, tried on two internet connections so assuming its an issue with

Same here… Online IDE can’t build, locally I can’t build and flashing to my photon just reboots it…


I cannot build nor flash from the cloud IDE. The build request “times out” (“server failed to process. Try later” error).

Is there a issue currently with the service?



Alright, I can confirm these issues on my end, and I’ve notified Particle about it. They should be looking into it soon. I’ll try to update here if anything changes.


Should be working again :)!

1 Like

Confirmed, thanks @Moors7

Can Particle make the status page more accurately reflect the status so this gets caught and fixed sooner in future please.

1 Like

I’m pretty sure they would if they could. There are just sooo many ways in which a system can fail that it’s almost impossible to catch them all. They do update failure cases if they encounter new ones, so they can be caught more quickly.
Luckily, there’s almost always one of the Elites online who has direct access to Particle in case something slips through like today :smile:

hmm, still seems like something is wrong. I managed 2 successful compiles followed by 4 failures.

Maybe they could do something like this:
Every 5 mins compile and flash some code that sends a webhook with an incrementing number.
Every 5 mins check a webhook has been recieved with the correct number.

I understand this would not help identify the issue but it would catch it fairly quickly.

Could you try refreshing your browser? Not sure why that’d help, but it wouldn’t be the first time that fixed something…
Flashing seems to work fine for me, I’ve tried it a couple of times.

I am using DEV, seems OK again now.

1 Like