Particle Boron SIM not recognized

Hi all, one of my boron’s is unhappy again, which is unfortunate because its already soldered in one of my boards and I don’t want to build another one. I was playing around with MQTT-TLS messages and didn’t get very far. Somewhere along the line it stopped sending data and wouldn’t flash OTA. I tried usb flashing old code on it which I knew worked, without luck. The behavior was that it would do the fast-blink cyan connecting to the cloud and never connect. Sometimes it would think it was connected but not send data. I went back and flashed old working code on it with the same behavior.

I thought I knew the problem… There is a known bug in our system where the device stops sending data… The fix/workaround is to pay particle more money, then the device usually picks up again with some delay. I went to the console to up the datalimit but according to the console the device was on a 3rd party sim. hmm, I couldn’t up the data limit in this state so I attempted to unclaim the device then re-claim it… I did so and it appears on my list again but when I attempt to up the data limit i get: Error: SIM with ICCID XXX not found.

also: particle v1.1 using particle data…