Optional aspect of 'Device Name or ID' not working in IFTTT


#1

Can the ‘New event published’ recipe be updated so the Device field truly is optional and/or allow picking an All option? Below this field in IFTTT it says “An optional id for a particular device” but I can’t figure out how to not include one, it’s a drop down with all of my devices.

I mainly use IFTTT to send me an email for certain publish events and it’s getting to be a pain to have to set them all up manually. I’d love to able to set a single IFTTT applet to send me an email anytime any device publishes an ‘email’ event, for example.

I tried using the browser dev tools to submit a blank device but got an error

{  
  "original":{  
    "type":"error",
    "code":"invalid_parameters",
    "message":"Sorry, there were some problems with your request.",
    "details":[  
      {  
        "message":"Please select a valid option",
        "parameter":"/stored_fields/~1triggers~1particle.events/core_name"
      }
    ]
  },
  "validation_errors":{  
    "stored_fields":{  
      "/triggers/particle.events":{  
        "core_name":[  
          "Please select a valid option"
        ]
      }
    }
  }
}

#2

Not sure if that’s possible, but you should be able to use the IFTTT Maker endpoint with a webhook, that can be triggered by any device.


#3

I ran into this same issue recently when I wanted to use IFTTT to listen for an event generated internally by the Particle Cloud (hook-response). It forces you to choose a device, it’s not optional (even though it says it is).