IFTTT and "No Options Available"


#1

I have a Photon Particle (This is used within a GameFrame) which I have created several IFTTT applets which work just fine. They still work as expected. Recently when I try to create a new one and get to the “Then That” phase and try to enter a function (which also usually shows the name of the device) simply shows “Options not available” and no device name. It seems sporadic since occasionally it does show up, but lately it is rare. I have tried editing the connection and granting permissions again, but it did not help.

Since IFTTT can clearly still talk to the device (can still turn it on and off, play animations, etc) I am guessing that they can see the device okay. Why would the “options no available” appear? Are the options coming from my device or the URL “https://api.particle.io/v1/devices/”?


No Options Found
#2

I think it is. Are you able to disconnect from the Particle channel and reconnect?


#3

I disconnected and then edited the connection. Now the options are showing but all the applets are created are now gone and have to be recreated. I hope this is not something I have to do often.

Update. After re-creating several apps successfully, then attaching to the device locally via internal web page, the going back to IFTTT, the options are again not available. If the options are coming from the Game Frame is it possible that the web page connection is keeping IFTTT from reaching the device to get the options? I tried rebooting the Game Frame but it made no difference.

Second Update. Rebooted my PC (since it was used to attach to the Game Frame web page) and now options are showing and the web page can be accessed. I’ve gone back and forth to both and so far they are still working. Not sure if the PC was not letting go of the connection which was keeping IFTTT from seeing the device. I wish I knew for certain.


#4

I’m having this same issue. I have no trouble with the existing recipes, but get the “Options unavailable” message when trying to choose one of my functions. Nothing has changed on my firmware in some time. Has anything else been discovered around this issue?


#5

@will


#6

Thanks for the ping! I didn’t have any existing applets that used Particle variables, but the function seems to be displaying correctly for me. The “Options unavailable” display only existed for me before I was running firmware that exposed a Particle variable.


#7

So if (like I have now) “No Options Available” even though I have set up functions already (and they still work) what would be the reason for IFTTT not seeing the options but still able to send it commands?


#8

Hey there – this view is for Particle.variable()'s, so you should only see that option if you’re creating an applet that uses a Particle.variable. You should not be able to view or select Particle.function()'s from that view.

The function selector should look like this, and should list functions regardless of whether or not the device is online. Can you confirm that you’re selecting the option circled in red?


#9

I see different options when I select the Particle action. I am using the actions (“Then that”) not using the Particle to be the trigger. Sometimes it will show up correctly, other times I see “options not available.”


#10

If I select the particle as a trigger and use the option you show it also shows “no options available”


#11

Hm that is super weird. I just tried creating a new applet with Particle as both the trigger and the action, and it seemed to work for me:

Do you see the same error when you create a new applet? Maybe there was an issue introduced by IFTTT when they rebranded from Recipes to Applets?


#12

Yes I see the same error whether I create a new applet or update an existing applet


#13

I get the same thing. Tried re-authenticating, but no luck


#14

I emailed IFTTT about this to see if they could see anything on their end. Haven’t heard anything back. In my case, I was trying to use the Alexa specific phrase to trigger a function.

Update from IFTTT:
Hello,

Thanks for flagging this. We’re aware of the issue and working with our team on a fix.

Thank you for your patience while we troubleshoot,

The IFTTT Team


#15

Although I haven’t heard anything back from IFTTT, it appears I can see my Particle functions now. @Iguanaman have you had any luck?


#16

Currently I can see them, but I have seen them before and then a day later (or later in the same day) they would not be visible. I don’t recall having the issues before IFTTT made their update. Hopefully it will stay visible. I’ve never gotten a response back from IFTTT despite asking them the same question when this thread originally started.


#17

It’s back to “Options Unavailable” again. IFTTT doesn’t seem to care and neither does Particle.


#18

Hmmm… I just checked from my phone and was able to see my functions. Would be nice to know what is going on behind the scenes, even though there’s probably nothing we can do about it.


#19

Maybe its your code…? How many functions are there? where are they in setup() relative to the rest of your code in that function?

I’d load up a bare minimum sketch and add in a couple of functions and a variable or two. Just to make sure.


#20

I had the same problem. Reflashing my device fixed it.