Nexus 5 Auto-Config Timeout

Hello Spark Community,

I’m Having trouble getting any response from my Spark Core. my Nexus 5 auto-config attempts have all ended in time-outs. My router (D-link DIR-855L dual band) is set for backwards compatibility (b and g bands). i have attempted connecting to both bands without success.

i moved on to try USB configuration and now am stuck at creating a USB connection with Putty. my driver installation appears to have worked properly, in device manager i see it on com6. What do I enter for host name?

i am using windows XP SP3 (bad idea, i know).

Please help.

Chris

note: several unhappy people commenting on the google play about nothing happening with Nexus 5 auto-config.

More details:
Router Band 2.4GHz, security: auto (WPA or WPA2), 80211 mode: mixed (n,g,b), channel 11

Hi @tallman64,

Happy to help! If you’re on Windows, and you’re seeing a COM port register for your core, then I’m guessing you have the necessary drivers to talk to the core over serial. I’m guessing you’re running into the same thing I did when I first used putty on Windows -> make sure you’re on the “Session” tab, and using the serial radio button, and not the “Serial” tab on the left:

https://community.spark.io/uploads/particle/_optimized/e31/e8f/093337628e_565x500.png

Alternatively, you can always install the spark-cli, and use spark setup to get your core going over serial: https://github.com/spark/spark-cli

I hope that helps!

Thanks,
David

1 Like

Hi Dave,

thanks.

some progress: I was able to connect to the Spark (clicking "serial’ radio button) and issue the “w” command. The Spark Led went from flashing blue to flashing green. something. tried “i” command immediately after and no response; just a non-blinking green rectangle in the session window.

tried unplugging Spark from laptop (disconnect sound ok) but when reconnecting: nothing. no sound and com6 no longer responds to Putty session attempt. Rebooting PC and factory reset on Spark allowed me to reconnect to com6, but then back to flashing green after “w” command.

Any Ideas?

UPDATE:

We have liftoff.

for some reason, the core did not like the 5GHz band but did not have a problem with the 2.4GHz one. after manual claiming, i tested with core plugged into a USB battery and D7 lit up the blue LED! thanks.

Chris (tallman64)

PS please look into why the Nexus 5 did not work “out of the box.” (i was very close to giving up on you)
PSS “i” command worked before the “w” command but not after.

2 Likes

Hi @tallman64,

Awesome, I’m glad you got thinks working, thanks for not giving up! :slight_smile:

We’ll continue to research the Smart Config issue on the Nexus 5. My suspicion is that the most up to date phones try very hard to stay in the 5 Ghz space, and avoid 2.4 Ghz whenever possible, making Smart Config difficult. We are working on another mobile configuration option that avoids this problem entirely.

Thanks!
David

1 Like