New Electrons Boot Straight to Listening Mode after uploading Firmware with Third Party APN


#1

I have a batch of 10 or so Electrons that are not behaving as expected upon registration. Essentially, I am trying to set them up with a third party APN as outlined here. Most of them so far (about 20) have worked perfectly; however, the last several have been booting straight into listening mode (blinking blue) after uploading the new APN tinker script as downloaded from the official Particle installation process.

Any idea why? Some posts said it was due to bad positioning of the SIM, but that seems unlikely…I’ve re-sat them many times already with the same result.


#2

Are the electrons running the correct version of the Particle system firmware? Electrons do not use automatic safe mode healer to update to the correct version like Photons do because it uses a lot of data.


#3

Also are all these SIMs already activated?
Does swapping SIM with a working device cure the problem?


#4

Yup. I’ve updated all of the electrons to 0.6.0 before flashing the new binary. I was able to get them all working except two. I fixed most of them by essentially starting the process over beginning with updating to fw0.6.0 and then flashing the binary with new APN.

I’m not sure why the last two aren’t cooperating, but I’ll try them again (and again).


#5

Yup. The SIMs are all activated and working. As mentioned in my reply to @nrobinson2000, all but two are now fixed.


#6

Update: It appears that all of the Electrons periodically are doing this (rather frustrating as I don’t know why). What is the reason a working Electron would be forced into listening mode? Is it more likely to be on the network provider of the SIM (no signal?) or on the firmware side…?


#7

I see some documentation on electron debugging here: https://docs.google.com/document/d/1NdYxPPk_i_mM2wM9oSbSZB1ElDlHA_x-IHY-UC7w62M/edit

but that requires compiling locally.

Maybe @BDub can give us better ideas on how to go about getting some useful information.


#8

If they are dropping straight into listening mode on boot it’s likely because they cannot read the SIM initially. Do your SIMs have a PIN set on them?

Try the debugging info, make sure to follow the 3rd party APN instructions and then see what’s happening during the modem::powerOn and modem::init sequences.

You can compile in the Web IDE or Dev or CLI with the new logging API if you are using 0.6.0. Instead of the log handler that the docs describe, use this one:

SerialLogHandler logHandler(LOG_LEVEL_ALL);

#9

There are no pins for these SIMs. I have 20 or so up and running already, but a few of the Electrons are being stubborn. I flashed them with the debugging tinker script and have confirmed that it says the SIM is not detected. I’ve tried with a few different SIM cards and tried re-seating it as well. Is this most likely a firmware issue or hardware issue? One of them worked for about 5 minutes before moving to flashing blue…


#10

@hagandh please check the height of the pins on the SIM card holder. If any look lower than the others by a significant amount, try gently pulling them up with tweezers. https://docs.particle.io/faq/particle-devices/led-troubleshooting/electron/#4-check-the-integrity-of-your-sim-card-holder

Also if you could take any pictures of issues you may find with the SIM contacts prior to bending them up, that would be helpful.


#11

Thanks @BDub for the information. I was already asked to send them back to you guys, which I did last week.