My Electron does never attach to my 3rd party network provider

Hi all,

So far everything is going well with my Electron and the Particle SIM card? But now I try to play with my Electron and getting the device connected to my local network provider.

I followed the exemples provided from the community as How to set 3rd party credentials for the Cellular network?

The SIM card I have is from Proximus (in belgium). And I’m making a simple exemple based on the Tinker firmware where I added at the beginning:

STARTUP(cellular_credentials_set(“internet.proximus.be”, “”, “”, NULL));

Here it is what happens when I boot the system up:Purple LED is waving for some seconds then permanently flshing bleu… With no connexion.

I tested my SIM on my phone where I removed the SIM code and test the internet connectivity…

Do you have any idea where this should come from?

Please note that I’m using the CLI to download the firm ware and I make a full power cycle between each code download to make sure the modem will bu updated with the parameters.

Thanks,

Gents,

Any good advise?

Hi Phelix,

I think the best option here would be to look at the system log output on an Electron running Tinker. This will show a bunch of processes that are happening on the Electron as it turns on the modem and makes a connection to the cellular network and Particle Cloud. Please follow the steps below to install the debugging software on your Electron, capture the logs, and then restore your unit to the standard firmware.

Debugging on the Electron

  1. Install the Particle CLI
  2. Put your Electron in Listening Mode
  3. Check the system firmware version of your Electron using the command particle identify
  4. Follow the instructions here. Make sure to follow the steps that match the system firmware version of your Electron.
  5. Reply back with the output you get from following those instructions. Let me know if you run into any trouble. I would advise that you remove you ICCID or IMEI before posting

Regards,
Harrison @ Particle

Hi Harrison,

Thank you for your help.
So I uploaded the troubleshooting software on the Electron. (my firmware is 0.4.8).
And I tried the tool with the partcile SIM card everyting is going well.
I change the SIM to my Proximus one and and after a full power cycle here it is the result for a and operation:

Turning on the modem: OK!
You will be prompted to enter your APN, USERNAME and PASSWORD.
Most 3rd-Party SIMs don't require USERNAME and PASSWORD so just
press ENTER on those to set them as empty values.
Pressing ENTER on all 3 will restore Particle's APN.

> APN: internet.proximus.be
> USERNAME:
> PASSWORD:

> Credentials Set!
> Connecting to the cellular network with 3rd-Party APN:

And it stays stuck on that line…

I also tried to scan the networks thanks to the command … Here it is the results:

> +COPN: "64
> +COPS: (2,"BEL PROXIMUS","PROXI","20601"),(3,"BASE","BASE","20620"),(3,"B mobistar","mobi*","20610"),,(0-5),(0-2)
> [ AT+COPS=5 ]    

Is this can be helpful?

Thanks,

BTW: all your docs are very clear and useful. We do not have all the time the chance to play with such well documented items. Congrats to the team!

1 Like

Hello,
I’m not getting any serial data output from my Electron with the troubleshooting firmware. What is the baud rate for the serial communications with this load?
I’m assuming it is:
8 Data Bits
No parity
1 Stop Bit
No Flow Control

But Baud Rate could be about anything.

Thanks

USB Serial is a virtual COM port that doesn’t care about baudrate (or the other settings) since it uses the USB report rate.
But if you are using Windows (before 10) you’ll need USB Serial drivers installed.

Thank you for the clarification. I was connecting my serial port to the Tx/Rx lines on the electron.