My core crash after updating

Hi, i powered up my core, it starts updating and then the activity LED close, only a small led blue is opened. I can reset to factory but can’t do anything else.


Please try performing a factory reset, send your Wifi credentials to the core and see how it goes?

It is exactly what i am doing, i factory reset, enter credentials with usb (because with app it NEVER worked) and it failed at updating.

The description you are giving is rather vague and there’s limited means for me to assist you.

1.) Is the core breathing cyan?

2.) Is the core listed in the Spark app?

3.) What is failing to update? Web IDE OTA flash? Tinker App flash via mobile app?

If you are unable to send the Wifi Credentials via Wifi to the core, there might be some configuration issues or procedure not done correctly.

You might want to review this and let us know which step you are stuck at: :wink:

[1] CC3000 Patch via DFU-util (windows):

[2] Spark-CLI on Windows:

1 Like

My description is perfectly clear and simple, when you connect for the first time after a factory reset, you are on version 1 right? It is flashing BLUE because it is waiting for credentials to connect to the WIFI. Then i connect it to USB in SERIAL to send the credentials. It works! The led start changing colors and it start and update (FLASHING PINK) it means update from what i learned. Then after updating the LED stops (meaning the LED is off) and only a small tiny led blue is on. I saw on the forum that it means the firmware is fucked. Now i need to factory reset again and it goes into a loop forever.

You can attempt to patch the core with a cc3000 patch and it should perform fine.

If you find it a hassle, do contact to have it replaced or further technical assistance.

Maybe it’s just me who can’t understand your description i guess. :wink:

Hi @Hugo411,

Is it flashing magenta immediately after getting to breathing cyan, without you doing anything? In that case it’s performing an auto-update, can you update the factory reset firmware by doing:

Install the CLI if you haven’t already -

1.) spark flash --factory tinker
2.) spark flash --usb cc3000
3.) spark flash --usb tinker


1 Like

Thanks, you fixed my problem

1 Like

@kennethlimcp that’s a neat flowchart! Where did it come from and is there a permanent link? I tried google but not much luck. I imagine this would be great to have on the docs site!