Mouse-wheel scrolling by pages in web IDE

This is happening on Firefox 88.0.1 (current stable).

Last time I checked in with the web IDE was back in January or so. At the time, mouse-wheel scrolling moved by about three lines, just as expected. Today when I loaded up the web IDE again, mouse-wheel scrolling is moving by a full page at a time. This is extremely disorienting, due to 20 years of muscle memory around the mouse wheel. :slight_smile:

I also tried this in the current Chrome release, 90.0.mumble. Over there, the scrolling is not quite as bad since it doesn’t move by a full page, but is jarring as well, since it moves by 8 lines instead of 3.

Given the different behavior in different browsers, I suspect there’s been a web IDE change to try to change the scroll behavior, and it’s not compatible across both browsers. Is there a way to turn that behavior off?

Scrolling by a full screen makes the web IDE basically unusable.

Thanks for any ideas!

I have the same problem. I didn’t experience this behavior just a few days ago.

It occurs to me that Particle may not have people reading this who can help. So I’ve also submitted a support ticket on the issue.

If we come to a conclusion in the ticket, I’ll relay it here.

I had already pinged staff to look into it and they will address it soon.

Oh, great, thank you! :slight_smile:

I did some JS debugging. I can’t tell for sure what the issue is, but I can say that when the wheel event comes in, the units on the deltas are pixels (which the javascript code doesn’t seem to ever look at), and the deltaY is 225 or -225 depending on the scroll direction. Then the code multiplies this by 5 before sending the result to the scrollBy method on the div.

In chrome, the script code served to the browser is different – it does not do that “multiply by 5” step. Additionally, the .deltaY value is 30 or -30, instead of 225. I can’t yet figure out where the difference is coming from though.

I also noticed that Web IDE ignores the mousewheel settings of about:config.

Hey all, we’ve noted this down (thanks ScruffR!), will take a look at this this week & provide updates.

Thanks!
Shaykat
Product Manager, Particle.

Was this issue ever solved? I’m still experiencing it in Firefox 90.0.2

Hi MickB,
We took a look at this, and the fix isn’t quite one we can prioritize at this moment. Apologies I don’t have better news on this. For now, we would recommend using Chrome for the best experience with Web IDE, or perhaps upgrading to use Particle Workbench.

Shaykat

Thanks for clearing that up. I’ll look into setting up workbench.