Mesh device setup failing with android app [Solved]

Are you suggesting that they monitor your mobile app and be able to watch how the % progress made?

There’s no cloud involvement when a BLE OTA firmware upgrade is performed.

Not trying to say that it’s acceptable for this to happen but I’m sure during testing phase (I did lots of testing too), we did not encounter this situation with a variety of mobile devices. :slight_smile:

1 Like

It really isn’t that hard of a thing to gather metrics. Generate a beacon when you start, on error, and on success. Seeing a spike in failures is a good clue that you have some work to do. If you can’t do that I really have a hard time believing that you could run any real cloud operation at even the smallest of scales.

Looking back this sounds a bit salty. My intention was to communicate there are ways to improve the developer experience. Particle has some cloud functionality. Monitoring and alerting is part and parcel of running one of those. So I thought it wouldn’t be a big deal to monitor how their tools were working for developers.

1 Like

Thanks for chiming in here. Indeed, we did not see this issue throughout our testing process and are thankful to individuals in the community for making us aware of the issue.

We’re compiling a list of known issues that will allow us to more easily share and communicate progress with the community and will be sure to include this as a high priority issue given that it disrupts the onboarding experience. More details to come.

1 Like

In addition to the thread started for tracking issues support responded to me that their Android guru has identified an issue with Android BLE services. Sounds like some progress is being made.

Thanks for this link, it was helpful. But after flashing the update, going into the app again to try to register/setup the device it still tries to update the device OS. Is that what you experienced too? Were you able to setup the device without the app?

At present you can only set up a mesh device using the iOS or Android mobile app.I am not sure why you got the update dialog the second time; I haven’t heard of that.

I’m having the same issues as described in this thread, including the trying to update after I have already updated via USB issue. I am using an LG V20 running Android 8.0.0 and I have the latest Particle app. At some point I did get past the required update screen for my Boron but then it failed on the mesh setup.

I also failed to connect to WiFi (IPv6 is disabled on the router) using my Argon. I tried to configure it after flashing via USB using the USB serial console but no matter what I do I get a rapid green blink.

I’m not very happy about how poor the device setup is. I’m guessing it will improve later but still a bad first impression. The mesh configuration should be able to be completed using a PC so troubleshooting and debug information can be collected easily. If there is a way to put the Andriod app in some sort of debug mode to collect information from it I would be all for doing this. I’m fairly competent with embedded systems but I don’t see a way to get more information out of the required app.

I hope in the next version or two the ability to configure the mesh is added to the serial interface of all gen 3 devices.

Ok so after much beating on things, I figured out how to get the Boron to complete the mesh setup.

Right after entering the mesh network password, but before continuing, hold the MODE button until it starts blinking blue again. Then when you hit continue it completes the setup. Without doing this it never gets past creating the mesh network on the particle cloud.

I also was able to connect a Xenon but that also had failures and took a lot of screwing around until it finally connected to the cloud. However, it kept saying it was failing to claim the device. Manually running the claim using the particle CLI worked but the phone app still was stuck on trying to claim.

In all cases, I had to flash the firmware via USB. That problem I still haven’t found a solution for.

I just received my first two Argons. I am now up and running using them as stand alone nodes but have failed to create a mesh network. Updating the firmware succeds but the android app never became aware, so I needed to abort the upgrade, but after adding the device again the firmware was updated.

I have the been able to add the devices as stand alone noded but when I try to add them to a new mesh network, the process stops after adding the Wifi network and before the device registers to the device cloud.

Any ide on how to force the device to create and join a mesh network?

Argons are by default gateways and currently there are only single-gateway networks supporte.
Hence you cannot add another gateway to an existing network (that’s also true when you removed the original gateway from the network since the concept of a “gatewayless” network is unknown to the system and hence when there already is an existing network any “new” gateway would be treated as additional).

If you want to create a new network you must opt for YES, USE IN MESH NETWORK (Yes, we already have complained about “awkward” choice of wording and that CREATE MESH NETWORK for the first gateway would be clearer :wink: )

After upgrading the firmware to 0.8.0-RC26 adding the Argon as a gateway to a new network nworks as a charm.



Have been travelling for $DAYJOB this week, will perform the wired upgrade to RC26 this weekend and report back.

1 Like


I updated the firmware on my Argon & Xenons via USB and the particle cli instructions.

After a false start where I tried to bring up a xenon without a mesh network within range (so I created a mesh network by claiming and configuring the argon first) - I was able to add 2 xenons to the mesh network - all using my LG G5 phone.

I exited the setup process at this point and tested these parts using the app to twiddle D7 on all 3 devices.
So far so good.

I go back to add more xenons to the mesh and now after I select the mesh network, I get this screen instead of the one where it says “joining the mesh network” etc etc:

The xenon is already flashing blue at this point, and continuing to scan the 2D barcode doesn’t help at all.

I’m a little baffled what backwater of the process that I’ve got stuck in, it seems like when I claimed and configured the first two xenons, I was in a mode where the app had maybe cached some info, and that got lost when I exited to toggle bits using tinker.

Maybe this is intended behavior - I’m not sure why the flow is different from the first two xenons I configured, but I’m unclear how to proceed.

What I had to do is put an already existing xenon node into listening mode and scan that bar code. Some sort of extra security I guess, whereby the already enmeshed xenon pairs up with the new one.

Although I’ve not had this issue, I’ve heard reports where people also were unable to use another Xenon as comissioner, but had success when using the gateway itself as commissioner. You just need to put it back into Listening Mode and scan it’s data matrix (just ignore the mentioning of Xenon in the commissioner comment of the app :wink: )

The most comfortable way to setup a mesh is when you start with the gateway, and then just keep hitting the ADD A DEVICE TO THIS MESH (or however it’s called in your mobile app version) button. This way the app keeps the mesh creds and secrets stored and reapplies them without the need for a commissioner.

The instructions on the Android app should be updated to match the instructions on the iphone. The iphone instructions are much clearer.

The 'driod instructions are pretty poor - it introduces the commissioner role with no explanation or context.

It seems like an issue that I have to bork a running mesh, by forcing the gateway into listen mode in order to add things to it. Especially when things apparently don’t need to be that way, as demonstrated by the “add device to this mesh” flow.

Now that people have confirmed my suspicions, and filled in the blanks a little, I’ll dork with the gateway.

The current difficulties with Xenons as commissioners that some users see are going to be addressed, but since that issue has turned up just recently (since not everybody can reproduce it with every device) a fix hasn’t been found before the release of rc.26 and postponing the release was no option either (for obvious reasons).

I can confirm that once you leave the “add another device to this mesh” flow, you need to put the gateway device into listen mode (at which point everyone else on the mesh lose their cloud connectivity and gateway functions), then scan the gateway with the app. That puts you back into the “add another device to this mesh” happy flow.

I now have several xenons + 1 argon gateway running simple tests using tinker.


This should be written in bold on the Pairing with your Xenon menu.
Which says that even if I scan a argon BTW)