Mesh (Argon/Xenon) fails to load firmware

Applied rc.26 today on all Argon and Xenon devices.
Had trouble with the IPv issue, which is now solved (Thanks for that!)
I can succesfully signal all devices, so all connections are fine.

But… Now I’m trying to upload the ‘blink a led’ example, which does not work.

The device (both with argon and xenon) status LED stays magenta (fixed) for ±1minute and then the led turns off (for multiple minutes) and then it restarts (sometimes) or I restart it via a powerswitch.

Afterwards, the example is not uploaded, the old firmware is running.

Thanks for the assistance.

I noticed the following feedback in the event tab:

spark/device/last_reset update_timeout titan_ranger 12/13/18 at 10:00:48 pm

I’m seeing something similar. Trying OTA update on an Argon, with firmware upgrade from 0.8.0-rc.25 to 0.8.0-rc.26. Cloud IDE reports Flash unsuccessful, and when I view the raw error log, it says Mandatory system firmware upgrade in progress. Try again after the device reconnects.

At this point, I get a magenta light which stays steady for several seconds, finally flashes/blinks a little bit, then turns off for a few seconds. Then it will light/flash magenta/go dark again, sometimes staying off for an extended time (10-20secs?).

If I hit the reset button, the Argon will come back online (breathing cyan) with my previous firmware running.

UPDATE: While I was writing this post, my Argon was still going through the magenta flashing cycles, and eventually came back up with firmware 0.8.0-rc.26 in place.

UPDATE 2: Just tried a Xenon. Same error messages. Same itermittent magenta flashing. Left it alone, and after about 7 or 8 minutes, it eventually came back up to breathing cyan, but still on old firmware. Trying again now.

UPDATE 3: On second try, the magenta flashing -> cyan breathing cycle was much faster (maybe a minute), and the update to 0.8.0-rc.26 succeeded.