Bugged Argon & Xenon, Perpetual and flashing Magenta

Hi all,

It’s my first time posting here so I do apologise if I have missed something out .

I’ve been having a rather irritating issues with my mesh boards, I bought them about a year back and finally got around to using them. But whenever I try to upload a basic blink sketch I receive the following issue.

The board flashes magenta, stays on magenta for a while, then shows no light, then back to flashing Magenta and the cycle loops.

The only way to snap the board out of it is to re-upload firmware via CLI, but when I try to upload new code with the updated firmware, I still get this issue.

Having this issue on 1 Argon and 3 Xenon, all brand new and out of the box so no prior code in them

When that happens you should leave your device alone for a while since it is trying to update the device OS in order to match it to the target version of your uploaded application.

When you have an old, untouched device it will probably have some older version of the device OS on it. So when you then build a new application it’s probably targeted at the most recent device OS version and won’t run with the old one. Consequently the system realises the mismatch and tries to pull in the new device OS which will cause multiple modules to update one by one (inidicated by the repeated magenta flashing & reset cycles).

In this forum we call this Safe Mode Healer update.

Hi Scruffr,

Thanks for the advice, I’ll try that.

Does the same logic apply to the Xenon? Supposedly the app stated that it had already updated it to the most recent software, but it faces the same issue.

This is true for all Particle devices.
However, if you should have happened to interfere with the auto-update (e.g. by resetting the device while it was doing it) chances are that you have left the device in a state where it won’t self-recover.

In that case you should install CLI and run the following commands in DFU Mode

particle flash --usb tinker -v
particle update -v
particle flash --usb tinker -v

After that the device should be good to go again and you should be able upload your application.

“Most recent” is a relative term :wink:
Most recent at the time when the Mobile App was released, most recent stable release, most recent pre-release, …

1 Like

Scruffr you are an absolute godsend, thank you. Waiting it out has solved the issue for all the boards.

I’ve been struggling with that all afternoon and am very glad it turned out to be something so simple. Thank you

3 Likes