Failed to flash to a argon board


The problem is the board always goes to magenta mode after I flashed the code. I also tried to re-setup the board, but still, have the problem.

I understand it is the safe mode(magenta) which means that I cannot modify the firmware. But get confused about why the problem still happens after resetting and not sure how to fix it.

Any suggestions would be appreciated.

The argon will also go magenta if you are targeting a higher firmware version when flashing. This is normal as it updates your code as well as the OS. Let it finish, could be a few minutes, then it should reconnect.



After flashing a code, my argon board turned to breathe cyan as usual but then began to blink red. So I reset the firmware as said in this link,

But it was still not working.

Any suggestions would be appreciated.

What was the pattern of the red flash? Single red flash in between cyan? Or an SOS pattern?

1 Like

No need to open a new thread for each trouble you have with one (even if repetedly) attempt to flash a devices.

BTW, the link you provided for the reset procedure applies to an Electron, that does’t necessarily mean it is meant to be used the same with an Argon.

1 Like

Thanks, Mjones. Today, I tried to flash a new code which is working under manual mode,


Then the red blinking seems to disappear. Also for another board with magenta light after flashing, after flashing the same new code, there is no magenta light any more.

At least, the boards are working now, although not sure why.

Thank you for your help and time.