Mesh device setup failing with android app [Solved]


#22

Have been travelling for $DAYJOB this week, will perform the wired upgrade to RC26 this weekend and report back.


#23

Update:

I updated the firmware on my Argon & Xenons via USB and the particle cli instructions.

After a false start where I tried to bring up a xenon without a mesh network within range (so I created a mesh network by claiming and configuring the argon first) - I was able to add 2 xenons to the mesh network - all using my LG G5 phone.

I exited the setup process at this point and tested these parts using the app to twiddle D7 on all 3 devices.
So far so good.

I go back to add more xenons to the mesh and now after I select the mesh network, I get this screen instead of the one where it says “joining the mesh network” etc etc:

The xenon is already flashing blue at this point, and continuing to scan the 2D barcode doesn’t help at all.

I’m a little baffled what backwater of the process that I’ve got stuck in, it seems like when I claimed and configured the first two xenons, I was in a mode where the app had maybe cached some info, and that got lost when I exited to toggle bits using tinker.

Maybe this is intended behavior - I’m not sure why the flow is different from the first two xenons I configured, but I’m unclear how to proceed.


LG5 not pairing with Argon or Xenon
#24

@AndyW
What I had to do is put an already existing xenon node into listening mode and scan that bar code. Some sort of extra security I guess, whereby the already enmeshed xenon pairs up with the new one.


#25

Although I’ve not had this issue, I’ve heard reports where people also were unable to use another Xenon as comissioner, but had success when using the gateway itself as commissioner. You just need to put it back into Listening Mode and scan it’s data matrix (just ignore the mentioning of Xenon in the commissioner comment of the app :wink: )

The most comfortable way to setup a mesh is when you start with the gateway, and then just keep hitting the ADD A DEVICE TO THIS MESH (or however it’s called in your mobile app version) button. This way the app keeps the mesh creds and secrets stored and reapplies them without the need for a commissioner.


#26

The instructions on the Android app should be updated to match the instructions on the iphone. The iphone instructions are much clearer.


#27

The 'driod instructions are pretty poor - it introduces the commissioner role with no explanation or context.

It seems like an issue that I have to bork a running mesh, by forcing the gateway into listen mode in order to add things to it. Especially when things apparently don’t need to be that way, as demonstrated by the “add device to this mesh” flow.

Now that people have confirmed my suspicions, and filled in the blanks a little, I’ll dork with the gateway.


#28

The current difficulties with Xenons as commissioners that some users see are going to be addressed, but since that issue has turned up just recently (since not everybody can reproduce it with every device) a fix hasn’t been found before the release of rc.26 and postponing the release was no option either (for obvious reasons).


#29

I can confirm that once you leave the “add another device to this mesh” flow, you need to put the gateway device into listen mode (at which point everyone else on the mesh lose their cloud connectivity and gateway functions), then scan the gateway with the app. That puts you back into the “add another device to this mesh” happy flow.

I now have several xenons + 1 argon gateway running simple tests using tinker.


#30

This should be written in bold on the Pairing with your Xenon menu.
Which says that even if I scan a argon BTW)