Mac high sierra and photon fails to setup

Hello

I’ve been strugling to setup a photon, having recently upgraded to OS high sierra. It’s a previously working photon, just haven’t used with this OS.

When usb connected it blinks blue, updated via dfu, particle cli uptaded (after having lots of trouble with npm and permissions)

"MacBook-Pro:~ bernardovalente$ particle serial wifi
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: Vodafone-F6DC5E
? Should I try to auto-detect the wireless security type? No
Attempting to configure Wi-Fi on /dev/tty.usbmodemFD121
? Security Type WPA2
! Something went wrong: Serial timed out
MacBook-Pro:~ bernardovalente$ particle serial wifi
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: Vodafone-F6DC5E
? Should I try to auto-detect the wireless security type? No
Attempting to configure Wi-Fi on /dev/tty.usbmodemFD121
? Security Type WPA
! Something went wrong: Serial timed out
MacBook-Pro:~ bernardovalente$ particle setup
 _ __             _   _      _        
| '_ \  __ _ _ __| |_(_) ___| | ___ 
| |_) |/ _` | '__| __| |/ __| |/ _ \
|  __/| (_| | |  | |_| | (__| |  __/
|_|    \__,_|_|   \__|_|\___|_|\___|
                 https://particle.io

> Setup is easy! Let's get started...
> It appears as though you are already logged in as bernas_123@hotmail.com
? Would you like to use this account? Yes

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet. 

> I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The device supports setup via serial.
setting up device 280022001447343339383037
> Obtained magical secure claim code.

Claim code set. Now setting up Wi-Fi
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: xxx
? Should I try to auto-detect the wireless security type? Yes
> Detected WPA(PSK/AES,TKIP/TKIP) WPA2(PSK/AES,TKIP/TKIP) security
Attempting to configure Wi-Fi on /dev/tty.usbmodemFD121
! Something went wrong: Serial timed out
Potentially unhandled rejection [3] Serial timed out (WARNING: non-Error used)
Potentially unhandled rejection [4] Serial timed out (WARNING: non-Error used)
MacBook-Pro:~ bernardovalente$ "

it then blinks orange (or red, dont know) several times and restarts blinking blue.

MacBook-Pro:~ bernardovalente$ particle serial wifi
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: xxx
? Should I try to auto-detect the wireless security type? Yes
> Detected WPA(PSK/AES,TKIP/TKIP) WPA2(PSK/AES,TKIP/TKIP) security
Attempting to configure Wi-Fi on /dev/tty.usbmodemFD121
! Something went wrong: Serial timed out
MacBook-Pro:~ bernardovalente$ 

i feel like i’ve done everything i could from whats available in here, could anyone help me?

thank you

EDIT: ps: i cant enter in safe mode, when i press setup+reset i and release reset when blinking magenta, the photon goes fast to white and fast blinking blue. dfu mode is ok. changed cables

Can you from there enter Listening Mode and then try particle serial wifi again?
BTW, when things don’t go to plan on first try, I’d steer clear of any auto-magic and try to do as much as possible manually (e.g. WiFi scanning, encryption selection, …)

I did try several manual setup in listening mode but with no sucess… any chanve it has something with my dual band router? I have a Vodafone-xxxxx and Vodafone-xxxx 5g, but i only tried to connect to the non 5g one

Have you tried entering LM from SM as suggested above?
If your 5GHz network has the same SSID as the 2.4GHz then that might contribute. Try renaming/deactivating 5GHz for the time being.

My bad, i meant to say that i cant enter safe mode because the photon automatic resets, blinking white and then enters listening mode. Im going to deactivate 5ghz, although ive only tried to connect to the 2.4ghz, they do have diferent terminanations

Even if your device can’t establish a Safe Mode connection (breathing magenta) after you release the SETUP button you are already in Safe Mode (just not connected) and hence can try to immediately press SETUP again to enter Listening Mode before the reset happens.
This at least ensures that your installed firmware won’t interfere with Listening Mode.

You could also try flashing my sketch from here via USB to do reset some of the sticky settings that might prevent connection if they ever were applied (accidentally or intentionally but got forgotten).