Latest Core Firmware did not seem to solve WEP issue


BLUF: I believe I had successfully flashed my core from the latest at GitHub in order to connect wireless using WEP encryption. Below, between the backslashes, are the serial communications in trying to setup the wireless. It did not work.

The serial message from Spark, after selecting WEP, was not that encouraging and the result even less. Read between the backslashes. Just as my core flashes green when I try to use the App to connect so does it after the flashing the latest build. I had copied pasted the SSID and Password from the Wireless Network Properties Security Tab into the serial terminal so it is correct.

After I flashed the core and failed to connect I tried to put the core back into listening mode. It will not and just goes to solid blue. I have to flash it again to be able to go into listening mode.

Any suggestions?

FYI: Putty did not work for me so I used the Arduino IDE serial monitor. That was tricky…


Your core id is 53ff64065067544825290187NNNNN
SSID: Race
Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2: 1

** Even though the CC3000 supposedly supports WEP,
** we at Spark have never seen it work.
** If you control the network, we recommend changing it to WPA2.
Password: EB4CADFAB653ACD799827NNNNN
Thanks! Wait about 7 seconds while I save those credentials…

Awesome. Now we’ll connect!

If you see a pulsing cyan light, your Spark Core
has connected to the Cloud and is ready to go!

If your LED flashes red or you encounter any other problems,
visit to debug.

Spark <3 you! 


I will say I have successfully connected and registered the cores at my home because I used WPA encryption. I had removed, unclaimed?, them from the WebIDE to see if I that would have been a problem trying to connect on my father’s network but then found out about the WEP problems. I wanted to entice him into the electronics realm once again but cannot demonstrate as the issues have prevailed. I do not want to have to redo his unteen wireless devices to change the encryption. I think it would be inhibiting. Would have been a great Christmas present but I guess not for now. Probably should come up with something more than flashing LEDs for the enticement but I am just very excited about these cores and I just got them. Cannot wait to make my other Arduino projects wireless. I will bring those around next time in hopes the WEP issue gets resolved.

@rrace001 Sorry you’re still running into trouble, we have not fully resolved the WEP issues yet.

As for getting back to listening mode, hold the MODE button for 10 seconds to clear out bad Wi-Fi credentials. If you have the app running at the same time it might be sending signals that the Core is catching, so stop the app to keep the Core from latching onto signals flying through the air.

Dear Zach,

Is the WEP issue solved yet. I am trying to use the Spark on a WEP network.

  1. I put the Spark in Listening Mode (Blue Blinking)
  2. I connect it using Putty Serial (Now it becomes Blue Solid)
  3. I select the SSID and WEP as the encryption method
  4. I key in my 26 digit of password
  5. Now it starts blinking Green, and keeps on blinking green, without ever connecting to the network.

Please help. I am destined to use it on a WEP network due to legacy hardware reasons, and cannot have the network configured to WPA now.



Hi Zach,

I have seen similar behavior on multiple WEP secured AP’s.
Reading TI’s wiki on Smart config ‘Limitations’ section, I quote:

“Smart Config - ascii WEP security without SmartConfig AES encryption doesn’t work. (WEP security with Smart Config AES encryption does work, same configuration is working with wlan_connect)”

So I think smart config for spark devices should offer a predefined AES encription key set so that WEP secured AP’s can work automatically with the tinker smart config feature