Issues installing Workbench's VSIX (combined from multiple threads.)


#1

I got the “Reload” prompt on all 3 extensions. I installed them in the correct order… theme, snippets, core last… I did not get the prompt to Install the Particle Local Compiler anyway for me to do this manually?


Tutorial: Installing the Particle Workbench developer preview
#2

I had the same problem. remove them, and install particle-vscode-core-1.0.0-alpha.3.vsix last, then you should get the popup


#3

Particle Workbench is awesome. I got it running in just a few minutes, pointed it at one of my projects, and it built without any modifications. It was really seamless and easy.

Question though, all of my builds logs start of with a long series of “fatal:” statements. Like this

cd "/Users/nash/.particle/toolchains/deviceOS/0.7.0/firmware-0.7.0/main" && make all
fatal: not a git repository (or any of the parent directories): .git
make[1]: Entering directory `/Users/nash/.particle/toolchains/deviceOS/0.7.0/firmware-0.7.0/main'
make -C ../modules/photon/user-part all
fatal: not a git repository (or any of the parent directories): .git
make[2]: Entering directory `/Users/nash/.particle/toolchains/deviceOS/0.7.0/firmware-0.7.0/modules/photon/user-part'
make -C ../../../user
fatal: not a git repository (or any of the parent directories): .git
make[3]: Entering directory `/Users/nash/.particle/toolchains/deviceOS/0.7.0/firmware-0.7.0/user'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/Users/nash/.particle/toolchains/deviceOS/0.7.0/firmware-0.7.0/user'
make -C ../../../hal-dynalib
fatal: not a git repository (or any of the parent directories): .git

Why is it “fatal” that these directories are not a git repository? Does something about the build system assume that they need to be in a git repository?


#4

Probably. It’s in alpha still so this is expected.


#5

Is this the full set of extensions pertaining to Particle when it is installed correctly? I’ve uninstalled and reinstalled numerous times, making sure to install in the order with -core last. But I never get an option to install a “Local Compiler” after reloading.


#6

I can not install local compiler. The download always fails at 100%? Same when I try the retry.
I can download the file shown in the error message with a browser.
Is there a log somewhere where I could get more information what fails?


[ISSUE] Install local compiler fails always (gcc-arm)
#7

hi everyone :wave:

just popping in quick to say: thanks so much for trying the workbench developer preview! we really appreciate your feedback :pray:

we’re working on a more formal “getting started” doc and improving the on-boarding experience in general but in the meantime, the “happy path” is basically:

  1. install the extensions (details above)
  2. select the menu option File > Open Folder and open the directory which contains all your Particle projects / source code
  3. open the Command Palette (View > Command Palette or ctrl/cmd+shift+p)
  4. run the Particle: Create Project command and follow the prompts

Once the window reloads, you’ll have a newly created project workspace where you can experiment with C++ IntelliSense and local compilation, import source code, add libraries, etc.

The three main areas you’ll be interacting with within a project workspace are: Commands, Tasks, and Settings.

  • to view commands, View > Command Palette or ctrl/cmd+shift+p and start typing Particle (docs)
  • to view tasks, select Terminal > Run Task… and start typing Particle (docs)
  • to view and adjust settings, open the .code-workspace file in the root of your workspace (docs)

I’ll try to quickly address some questions here but if you need more info, don’t hesitate to report an issue.

@seulater

So whats the best link, thread to be watching to get all the latest updates on this?

you are in the right spot :slight_smile: we’ll be super-vocal in the Particle Workbench category and likely be sending out email alerts as appropriate.

@rvnash

all of my builds logs start of with a long series of “fatal:” statements

yeah :frowning: that’s a scary message but it’s actually not a problem. please ignore. sorry about that!

@bloukingfisher

I never get an option to install a “Local Compiler” after reloading.

try relaunching VSCode itself and if that doesn’t help, please report an issue

@TimGTech

if you are logged in, should it not show your devices?

yes, it should. in time :wink:

@bittailor

The download always fails at 100%

:thinking: that suggests the checksum step of the install is failing. if you are able, please try a more reliable network. if that doesn’t help, please report an issue

thanks again everyone!


[ISSUE] Install local compiler fails always (gcc-arm)
#8

I did this in my original install as I mentioned in my post. I’ve uninstalled all 3 and reinstalled them with CORE installed last. No luck. I’ve restarted vscode a few times. I don’t get a prompt to install the compiler.


#9

Was excited to try this out but, sadly it failed for me…

Updating CLI... Timed out while updating
 !   Error in particle-cli:
 !   Cannot find module 'babel-polyfill'
 !   See C:\Users\xxxxxxx\AppData\Local\particle\error.log for more info.

Update:
Little googling and ran:

npm install --save-dev babel-polyfill

Now I have this error when running: Particle: Create Project

! Error loading module 'serialport': Cannot find module 'object.assign'
Please reinstall the CLI again using npm install -g particle-cli

I did install particle-cli as the error said but still get the same error when I try to create a project.


#10

When I install the 3(themes,snippets,core-workbench) I never got the prompt to install the local compiler. When I try to do it manually, … I click on the GEAR icon and select Particle: Install Local Compiler i get an error:

command ‘extension.installToolchainDependencies’ not found

none of my Command Palette Particle: commands are working… for example if I choose Particle: Login i get error command 'extension.login' not found

any help on this would be appreciated. I really want to try Workbench!


#11

@bbeardmore
I had the same problem as you. I had visual code 32bits from a long time ago. So decided to move to 64 bits. I uninstalled the 32 bits then install the 64 bits and then since I had already the extensions installed, it inherited it.
When I ran Visual code again, I tried to run the login command and it worked and also I got the prompt to install the arm compiler and also all the commands were found. I just ran my first compilation, it takes far longer than the web ide :slight_smile:
So why did it work? I don’t exactly know but could be because I had the particle client installed on my PC after install visual code and since I have not rebooted my PC after that, the path to run the particle command in the environment variables was not applied on the system.
You could try to reboot your PC and try again or uninstall visual studio and reinstall it after installing the particle client so that the path is somehow found by visual studio.
Hope it will work for you.


#12

@damonzon
Right On! That was it. Hopefully this will help others! I was on an old 32bit version. I followed your steps, installed 64 bit version and got the prompt to install compiler… and everything is working now

I copied my project into a new workspace. The first compile was quite long, errored out… I needed to install the libraries… did that… compiling a bit quicker now

next error I got was an APP_FLASH overflowed by 26,468 bytes. any thoughts on what may be causing this?

the WEB IDE however compiles my code fine:

Output of arm-none-eabi-size:
text data bss dec hex
54924 484 3200 58608 NaN

In a nutshell:
Flash used 55408 / 110592 50.1 %
RAM used 3684 / 20480 18.0 %

Error I get when I do LOCAL COMPILE through WorkBench is:

c:/users/bbeardmore/.particle/toolchains/gcc-arm/5.3.1/bin/…/lib/gcc/arm-none-eabi/5.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe: c:/Users/bbeardmore/Dropbox/PelletPirate/PelletPirateC++_WB/target/PelletPirateC++_WB.elf section .text' will not fit in regionAPP_FLASH’
c:/users/bbeardmore/.particle/toolchains/gcc-arm/5.3.1/bin/…/lib/gcc/arm-none-eabi/5.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe: region `APP_FLASH’ overflowed by 26468 bytes
collect2.exe: error: ld returned 1 exit status
make[1]: *** […/build/module.mk:225: c:/Users/bbeardmore/Dropbox/PelletPirate/PelletPirateC++_WB/target/PelletPirateC++_WB.elf] Error 1
make[1]: Leaving directory '/cygdrive/c/Users/bbeardmore/.particle/toolchains/deviceOS/0.7.0/firmware-0.7.0/main’
make: *** [C:\Users\bbeardmore.particle\toolchains\buildscripts\1.0.0\Makefile:34: compile-user] Error 2
The terminal process terminated with exit code: 2

Press any key to close the terminal.

any ideas on how to address this?


#13

@bbeardmore
I have not ran into that issue.
Have you set the target device in the preferences settings of the extension?
If you compile and it still fail, you can try to do a clean application and then compile again.


#14

I have the same issue where none of the particle commands work. I also never got the prompt to install the local compiler. The theme, snippets and core extensions installed fine.
I have a 32bit Win7 machine and the 32bit VSCode. Is 32bits supported?
Is there a way to install this particle extension manually?

image

I just installed VSCode,so no additional extensions loaded:
image


#15

Hi @Pescatore,

Sorry you’re running into issues. 32bits is supported, although a limited number of people have tried it on Win7+32bits. Can you please provide more details about your system per this thread?


#16

Hello @jberi, I hope this is what you are looking for:

Supporting information

  • VSCode Version: 1.28.1
  • OS Version:Windows 7 Home Premium with Service Pack 1
  • Other extensions installed: None

Steps to Reproduce:
1.Download and install VSCode.
2.Install Particle extensions: theme, snippets, core.
3.Clicked on prompt to reload.

Launch with code --disable-extensions to check. Tried this, but I think it’t not for this issue
Does this issue occur when all extensions are disabled?: N/A


#17

Can you also confirm if you’ve installed Visual Studio Code as a System Install or User Install? Microsoft is now recommending the User Install where possible.


#18

I picked 32bit User Installer, which dowloaded VSCodeUserSetup-ia32-1.28.1.exe.
I ran it and it installed VSCode.
image


#19

I, too, could not get the extension to work until I switched to the 64-bit version.

screenshot of VSCode About dialog


#20

Hi @jberi, I am still unable to use Workbench. I installed the latest version 4 extensions.
I still don’t get the prompt to install the compiler and the Particle commands don’t work.
My setup is still the same as described in this thread.

I do get a new error when VSCode starts up that says: server returned 502.

In the main.log file I found:
[2018-11-01 22:00:17.793] [main] [info] update#setState idle
[2018-11-01 22:00:47.795] [main] [info] update#setState checking for updates
[2018-11-01 22:00:48.614] [main] [error] Server returned 502
[2018-11-01 22:00:48.614] [main] [info] update#setState idle

Could VSCode be trying to download the compiler and can’t resolve the server address?