[ISSUE] CLI always aborts when running particle command

I’ve been using a particle Argon for a few days now, primarily via the web interface. Blinked the LED, got some notifications from the Argon to the cloud working. Then I setup some i2c hardware and decided I might have to debug at some point so I connected the particle/Argon debug interface and decided to install the workbench in VS Code. It all seemed to go ok, and I get the particle welcome screen, command pallete. But if I try to run any commands I always get:

bash-3.2$ particle --help
particle: Adding dependencies…
▸ Get “https://binaries.particle.io/node/v12.16.1/node-v12.16.1-darwin-x64.tar.gz”: dial tcp: i/o timeout

▸ Error rebuilding packages.

▸ Try running again with GODE_DEBUG=info to see more output.
particle: Installing plugins…

▸ fork/exec bin/node: no such file or directory
particle: Installing plugins (retrying)…
▸ Error installing package.

▸ Try running again with GODE_DEBUG=info to see more output.

Any and every particle command ends this way. I tried to figure out what “GODE_DEBUG=info” is, but couldn’t find any info on the web. I did find "GODEBUG=schedtrace=1 commands described so I tried that. “env GODEBUG=schedtrace=1 particle”. and that seemed to return ‘GO’ language scheduler messages. I get the same messages when I try to install the CMD line tools any time I run particle.

I tried installing the automatic way, downloading with Safari (even though my version shouldn’t require it apparently) and installed into the usr/local/bin directories as root with the recommended ‘unsafe’ incantations listed in the documentation. I installed node and npm manually and both seem fine.

Also, note that the error message lists a different version (12.16.1) of node than I have installed, even though I installed the recommended LTS version (12.16.2). While the error message says the connection timed out, when I get that file from a browser, it comes in just fine.

The file ~/.particle/error.log just contains the above error repeated.
Nothing much in the audit log

Any suggestions to getting this installed, or how specifically to ‘run again with GODE_DEBUG=info’.

MacOS Mojave 10.14.6 64bit Intel

particle version - won’t run, but downloaded April 27 2020mba:~ robm$ ls -al ~/.particle
total 264
drwxr-xr-x 6 robm staff 192 28 Apr 21:20 .
drwxr-xr-x+ 133 robm staff 4256 28 Apr 01:43 …
-rw-r–r-- 1 robm staff 53 27 Feb 22:32 autoupdate
-rw-r–r-- 1 robm staff 69361 28 Apr 21:20 error.log
drwxr-xr-x 2 robm staff 64 27 Feb 22:32 node_modules
drwxr-xr-x 7 robm staff 224 27 Feb 22:32 toolchains

mba:~ robm$ node -v


mba:~ robm$ npm -v


mba:~ robm$ which node


mba:~ robm$ which npm


I have tried both automatic and manual installation.

ah, sorry for the bumps :pray:

your best bet is to manually reset the CLI:

(i just added some detail there)

otherwise, this troubleshooting info would be super-helpful:

Thank-you m_m
Resetting the CLI files did the trick. I only had 4 files/directories, not all the one’s you listed (I listed mine in the original post)

I wonder if the file ‘node-v8.15.0’ was the problem, because that doesn’t match the version of node I have (also in my original post)

Thank-you again for the super fast response, I have the Workbench working for the first time!

Any chance you know why the error message referenced GODE_DEBUG? Should that have been GODEBUG? Do you know if Particle Workbench/CLI uses ‘Go’ programming language/environment?

Resetting the CLI files did the trick.

ah, glad you’re back to working. sorry again for the bumps :pray:

Any chance you know why the error message referenced GODE_DEBUG?

hoooboy… long story :sweat_smile:

we currently support two installation paths: “standard” (docs) and “advanced” (docs). workbench always uses the “standard” install. in the “standard” scenario, we provide a wrapper .bin written in go which handles installing the runtime dependencies (node, npm, and the particle-cli package itself) required to run the CLI. it acts as a proxy; when you run any command, the wrapper bin first ensure it has its dependencies - installing them if need be - and then forwards the command along to the particle-cli package to execute. well, sometimes this wrapper bin misbehaves, things break, and it prints out that debugging info :hugs:

overall, it’s… not super-awesome… fwiw, it’s my personal mission to get things knockd into shape and rock-solid but for lots of silly reasons that’s taking a bit :wink:

thanks for your patience :+1: