CLI 'particle update-cli' timeout issue

Hi, Raising this as I can’t find it answered in specific terms elsewhere.
I am attempting to update the CLI, having not used it for a while. The current version is 1.27.0. It did attempt an auto-update when I first started it, but timed out.
When I first installed it, using the installer, it ran for several hours… it seems to have an extraordinarily slow link to the github server, or mirror, as far as I can tell. I am guessing that it’s now having an equally hard time retrieving update data from the server and timing out.
I don’t know why this would be. I have a local internet connection speed in excess of 40Mbps - but the ping latency to California (from Perth, Australia) is a pretty poor 200mS+. I don’t really know enough about node.js to understand the process beyond general terms, but maybe it’s very chatty.
At the moment, I am repeatedly running the particle update-cli command in the faint hope it’s pulling down a little more each time, before timing out.
So… is there another way to update the CLI, or is there any way to extend the timeout, so I can leave it trickling down overnight?

What OS are you using? I can’t flush out from your post if you are using Windows, Mac, or Linux. If Windows, running the installer is the best method as it updates everything. I have no idea if that installer contacts github or if all code is all wrapped up in that installer file. I’ll defer on that one but still please state your OS for the record.

My bad! Windows 7 32-bit. I may have to resort to a re-install, since it keeps going with slow networking. I was hoping for a hidden parameter or config tweak I could use to tell the CLI update-cli processes not to time-out.

Slightly more information: One of the repeated attempts just popped up with:

C:\Users\apt\Downloads\firmware>particle update-cli
 ▸    Error updating CLI
 !    Get dial tcp: i/o timeout
Updating CLI...

Unless my repeated requests are now being blocked as a potential DOS attack, of course!

I have resorted to a re-install which failed… sigh. I’ve posted my new issue under existing topic, dealing with the error pattern I’m now getting. This one can be marked unsolved, but please don’t spend time responding on my behalf, thanks.

Have you tried running a trace to see if you are just having network latency or other issues?

i.e. traceroute

It looks like a general network issue and not anything specific, IMHO. I could be wrong.

For completeness, my particle-cli re-install worked - eventually - once I completely disabled my internet security suite (Kaspersky), restarted the machine, and retried it.

Interference from the AV file monitoring/network protection may also have been the cause of the initial issue reported here, but that’s unproven. Worth recording for future reference, at least.

1 Like