Latest Particle CLI not Installing

Hi, Panic here.
All going well until last Saturday night my Electron started breathing purple after a local program change using Particle CLI. Hit this before, sign that Particle has updated its firmware, correct, change to 0.5.1 Correct, left my upgrade till this morning.
Following instructions I try to upgrade to the latest CLI using npm update -g particle-cli, this took out my existing version of CLI and did not update to new one. I tried updating to latest version of node.js to see if that was the problem, no it is not.
Seems as though npm is not finding the correct git hub location?
Instructions I followed
How do I post a file to this so that you can see my npm-debug file?
Now I am up the creek with no paddle. Anyone else in difficulty with this upgrade and has it been resolved? I don’t think I am doing anything wrong at my end. Thanks

The issue seems to be that node (npm) could not find git on my computer, which I don’t think I ever installed before and particle cli worked OK etc.
However installed git from and node then installed particle cli and I was able to upgrade the firmware on the Electron. Was I missing something here, did npm have a version of git which was no longer relevant to the new git site? Searching for some meaning in the universe here

I have the same problem. Do we need git installed locally now? Or is this a mistake in the latest CLI installer?


@dperrigan & @pNrie
@jvanier has just pushed a new version (1.14.1) of CLI that doesn’t require Git anymore.

Just try npm update -g particle-cli again

Awesome. Just confirmed that it works.

Thanks, all.