Problems with npm install -g spark-cli

So I’ve been playing around with spark for a couple of days now… And the initial version that I had was node-v0.12.2-x64.msi. Apparently the installation was fine and I could use it for a couple of days after repairing the files but recently I started having issues with installation. ‘Spark’ command suddenly went unrecognized and I tried to reinstall the files, realized there was a new update ( node-v0.12.3 ) and uninstalled the old one and tried the new one. But when i tried to input the command ‘npm install -g spark-cli’ I was given this error. Is there anyway someone can help me solve this? Any help would be greatly appreciated ! Thanks :smiley:

Hi @wilsoncys. Try installing the new cli with npm install -g particle-cli. I would suggest giving that a try and seeing if that resolves your issues.

You can find the npm documentation for the Particle CLI here.

hi @gaudsend i tried it and it still doesn’t work. any other solutions?

I tried the windows method as described in the help
and its not working either…

Hi @wilsoncys, the error messages says that you don’t have Git installed in your computer.

You can install it from here:

During setup, pick the option showed below:

@sazp96 Installed git. Same error occurred. Tried on a different laptop. Doesn’t make a difference either…

When you install something that changes the PATH variable in windows, it doesn’t immediately update it for any Command Prompt window that is open. Have you tried closing the command prompt and opening a new one ?

I installed the Particle-CLI this morning and used this implementation of GIT - it worked first time (after running into an identical problem regarding a lack of git installation)

Hi all! Thanks for your patience with this. We will have the git dependency fixed sometime this week.