[ISSUE] Boron firmware update fails at updating bootloader

I’ve got a Boron BRN404X that fails firmware update when it reaches the bootloader stage. It updates softdevice and system part1, but then when it resets to flash the bootloader, it fails after a timeout. The light stays magenta for about 50 seconds, then off for 30 seconds, then back on for 50 seconds. Other times, there has been some variation in the magenta blink pattern.

I had it successfully flash once, but I have not had repeated success. I’ve tried several USB cables with no effect. I have another Boron that operates correctly.
I've tried the 5.x.x versions as well, and they won't update either.

Any other steps I could try?

  1. Search in the community for similar reports
    Similar issue: Failed Boron Firmware Upgrade

  2. Verify you are using the latest versions of the CLI

    • Verified: v3.17.3
  3. Disable Antivirus

    • No effect
  4. Bypass USB hub/extensions

    • no hub used
  5. Check your USB Cable

    • several cables tried; same result
    • I have another Boron where firmware update works fine every time

Have you tried Device Restore USB | Tools | Particle?

I did not try your suggestion about the Device Restore USB page. But as usually happens, shortly after posting this, I found that putting the Boron in Safe Mode reliably enabled firmware updates. It wouldn't update in DFU or Listening modes. Thanks.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.