Iphone Particle app Tinker has disappeared

iPhone 7 running iOS 10.2 and Particle app 2.1. Photon setup went smoothly and Tinker was available and worked.
Now i reopened the app and it sees my photon, but Tinker is not there. All i have is “your devices” and “device inspector”.
Deleted the Particle app and reinstalled and reflashed Tinker, but still no Tinker on the app.

If you still have the factory default Tinker firmware running it will say so and you just need to tap the row for the device and you’ll back in the Tinker screen.

Tinker is a feature of the default firmware. Once you flash your own program, like blink an LED, tinker won’t be available anymore because your Photon is now running blink, not tinker. On iOS you can put it back by clicking on the device, then the button in the upper right and then selecting Reflash Tinker.

It’s also possible to mix the Tinker features into your own user firmware on the Photon so you can use both features at the same time.

Thanks for your help. I thought Tinker would always be available. But, “reflash Tinker” does not work for me.

You could try putting the Photon in safe mode first. Hold down RESET and SETUP, release RESET, but continue to hold down SETUP until it blinks magenta. It will go through blinking green, blinking cyan, fast blinking cyan, then go to breathing magenta. Then you should be able to Reflash Tinker.