iOS sparkCloud problem

I was able to create my project and include both Spark-SDK and Spark-Setup using cocoa pods!
I need help!!!

My problem is when it’s time to compile I get the following error :smile:

Undefined symbols for architecture x86_64:
“OBJCCLASS_$_SparkCloud”, referenced from:
type metadata accessor for __ObjC.SparkCloud in ViewController.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Someone can help me??

Weird. Whats the process you went through with pod?
Is it s swift or Obj-C project?


I used a swift project.
It’s been like 1 month and I can’t find the solution

Did you create bridging headers?
Have a look here on some cool video tutorials created by a fellow community member:

Yes, bridging hearders is created! I’m able to use the spark function.
My only problem is when I compile. I get the error mention previously.

I will try to see from the video’s tutorial if I’m missing something and I will let you know.

@goncalo, I would recommend trying @demented video tutorials. I tried them and they worked so my system is find.

Please do this to make sure your system is working find then look into the project with the errors.