IOS SDK Xcode build fails

Has anyone run into this issue? Whenever I build my project I get the following:

Undefined symbols for architecture x86_64:
OBJC_CLASS$_SparkCloud”, referenced from:
objc-class-ref in ViewController.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

I am using Xcode 8.2.1

Ay help is much appreciated. Been stuck on this all day.

Hate to ask, but have you checked the following topics?

Hi Moors. I have tried everything listed I found in the forum, no luck still.


Wondering if this a version issue? A little more about the issue. I was able to use cocoa pods about 3 months ago on a 2014 MacBook Pro. I recently upgraded to the new MacBook Pro. Not sure which version of cocoa pods I was using, but I am thinking maybe if I roll back a few version it would Solve the issue. Just a thought.

Anyone from particle able to add any information?

I tried rolling back Cocoapods to 1.0.0 but had no luck resolving the errors…

@ido can you offer any help or assistance?

another update: tried rolling Xcode back to 7.2, same error.

Did the pod install / update command ran successfully?
Can you post your Podfile ?

Did you try running it on a device or just the simulator?

@ido , Below is my pod file. I have tried many different variations of this that I found on the forum, all produce the same error. The pod file did install successfully. I get the same error when I run on a device.

# Uncomment this line to define a global platform for your project
# platform :ios, '9.0'

target 'shades' do
  # Comment this line if you're not using Swift and don't want to use dynamic frameworks

  # Pods for shades

  target 'shadesTests' do
	pod “Spark-SDK”
    inherit! :search_paths
    # Pods for testing

  target 'shadesUITests' do
    inherit! :search_paths
    # Pods for testing


Well there we go, please remove the use_frameworks! directive and try again (after running pod install) - as the iOS SDK is built as a library and not as a framework. If you prefer/need to use frameworks revert to using the Carthage version of the SDK.

@ido great, I will try this when I get back to my desk. Thank you so much!!! I will keep you posted.

@ido Thank you that solved the problem!!!