iOS 10 rejects a Photon in setup


For what it’s worth, I’m also trying manual setup through USB/terminal and my Mac cannot connect to the network either (same reason - no internet connection). It gives me this error when I get to the step asking if I want to manually enter my Wi-Fi network configuration:

? Would you like to manually enter your Wi-Fi network configuration? No
▐ Asking the Photon to scan for nearby Wi-Fi networks…events.js:160
throw er; // Unhandled ‘error’ event

Error: connect ENETUNREACH - Local (
at Object.exports._errnoException (util.js:1022:11)
at exports._exceptionWithHostPort (util.js:1045:20)
at connect (net.js:881:16)
at net.js:970:9
at _combinedTickCallback (internal/process/next_tick.js:67:7)
at process._tickCallback (internal/process/next_tick.js:98:9)


How about answering with “Yes” here?


I tried entering it manually, but when it actually sent the information to the device, it returned the same error.

I think I just found a work around, though. Instead of doing particle setup, I first did particle serial wifi on the terminal. I was able to connect the photon to the wifi network, but it wasn’t claimed on my account. I then put the photon back into setup mode, and ran particle setup. This time, setup went through without any errors and I was able to set it up (in this case, I did NOT enter my Wi-Fi network configuration manually, it was able to pick it up). Once I completed this setup, it appeared as claimed in my particle app (without a name). So… I didn’t quite find a “solution,” but I was able to register my device.


Did you manage to solve the issue. It was something inside the loop?
I am having the same error of No internet Connection and the never ending loading. But on android I am also having problems, it says retrieving ip address and never ends.