IFTTT Login not working


#1

Hey! Trying to create an integration with IFTTT and the Particle login is not working. I input the correct username and password, and all I see is a blank message form:

That dark blue square appears on login attempt. i am sure it is supposed to say something but it does not. And I do not get logged in.


#2

Could you make sure that you capitalise everything correctly, or perhaps without caps. I may appear that some services are case sensitive.


#3

Hi @BarryAllen,

Looks like the error prompt there is having an issue, but the IFTTT login is working at the moment. Were you able to login after checking your capitalization?

Thanks!
David


#4

I was able to get in after reseting my password, though I copied the same password from a notepad just to be sure I wasn’t crazy, and it worked to login to build.spark but not ifttt.

But I was eventually able to get in.


#5

I had the same issue.

Changed my password - didn’t help.
No Caps in Email - Works!

Thanks for the hint


#6

Thanks for the heads up, that sounds like a bug on our end, I opened an issue for it.

Thanks!
David


#7

Was this ever resolved? I’m getting the same issue.


#8

I was having the same issue, but I think I figured it out:


#9

Is this still a problem? As far as I can tell I’m following all the advice; lower case email address, not using the community account but it still won’t work. I do have a long password if that makes any difference but I tried a fairly short one (Safari-recommended one) and that didn’t work either. I’ve also tried Safari, IE, Edge and Chrome and the site does the same weird dark grey bar thing and won’t let me in!


#10

Hi @SmokeWrangler,

I don’t think this is still a problem, I just deauthorized / reauthorized the Particle channel. After checking the logs it looks like you’re capitalizing the first letter of your username during the authorization, make sure it’s typed lowercase.

I hope that helps!

Thanks,
David


#11

Hi David,

Thanks for the quick reply. You’re right, I was doing that right up until I read this thread but I’m definitely not doing that now and I’ve still got the same problem.
The only thing I can think of is there’s something wrong with my password. Is there a limit on the length or type of characters in the password?


#12

Hi @SmokeWrangler,

Hmm, I don’t think limits would be a problem, if you can use those credentials to login to particle, they should work fine in the oauth box.

Hmm, frankly I’m not sure why its not working for you. Can you try creating a new account (simple email / pass), and trying that from where you are, and see if that works for you?

Thanks,
David


#13

Hi David,

I did as you suggested and it worked! Thanks!
Now to set to work! :grinning: