iDE issues, bugs, annoyances

I’ve been using the web IDE to compile my code for a while now, mainly because the standalone compiler doesn’t work in XP. And I’ve found a number of issues that bug me. In no particular order:

  • When you hit a compile error, the line displayed in the error messages is not the actual line at which the error occurred. The line number is right, but the text displayed is for some other line.

  • When I touch the mouse to some character in the middle of a line, the entire display jumps to the right to put the point I touched in the center of the window. This is essentially never what I want to see. Now the entire left side of my code goes off-screen. Please lock the screen to the left edge.

  • The color palette of the Web IDE is, uh, awful. Comments are in light gray on a dark gray background and nearly illegible. Other stuff is red or yellow or white or purple, it’s like Mardi Gras. Could we please have an option to disply the UI in black and white?

  • Speaking of color, if you do an #ifdef, the purple follows through to the next line, for some unknown reason.

  • When you compile a program, it goes “Great work!” or something, but only for a few seconds, then reverts to Ready. If I divert my attention to something else and come back to see Ready, I’m left to wonder, OK well did it work or not?

  • (Personal opinion) I don’t like the animated pull-out/slide-out UI for accessing commands. What was wrong with the standard drop-down menus from the top that everyone knows and have worked well since forever?

  • OK, it’s a GUI. With no editing capability. Yes you can cut & paste stuff but what if I want to find some instance of a particular name? No Find command. No Replace command.

  • Speaking of, some sort of parenthesis matching would be nice. Ie. touch a “{” and it highlights everything to the next matching “}”.

  • The bottom line now shows the status of the currently connected Photon by, apparently, mimicking the status of the RGB LED. That’s cool, only it’s wrong. I can unplug my Photon and the IDE still shows it pulsing (excuse me, “breathing”) cyan.

  • The Save button is still grayed out.

  • When you select the apps tab, the list of your apps is sorted in apparently random order. Could this please be sorted alphabetically, or by last used or something?

  • In the Particle Devices tab, when you click on a device, a gray star jumps to the left of its name, making you think that that’s now your current device to flash to, Only it isn’t. You have to also click on the star itself to do that. Counterintuitive.

  • The text (also in camo light gray) in the tabs at the top of the page gets clipped if it’s longer than the size of the tab. So I have two tabs both named spark-dallas-te. One is .cpp, the other is .h. Which is which? Who knows? Mousing over the tab brings up the full name of the file - in tiny text at the other end of the screen. Maybe that could pop up where you’re looking - at the tab itself.

  • Some sort of source code versioning would be a nice added touch.

So there.

4 Likes

@will, some feedback here for Particle tools.

Hi @Michele

Just one more question if I may: what browser are you using for the web IDE on XP? Internet Explorer?

You are going to have a much better experience with a modern web browser such as Chrome or Firefox.

1 Like

Yes, I’m using Chrome.

And I probably should add that overall, the IDE is a good tool and works well. It hasn’t ever eaten my files, not like the Nextion display editor. But these are just a few things that seem to come up every time I use the IDE and make me wish gee, it would be nice if it worked differently.

2 Likes

This question is easily answered by clicking on the Ready! item which will reveal the last build result - error or success output.

CTRL+F and find next is CTRL+G

Would be nice, but proper indentation does most of that too. That’s what the vertical lines are for :wink:

For how long after unplugging? The cloud has to learn of the new status before it can inform your browser of the new circumstances.

Nope, not random, but chronological by creation time (at least that’s how it should be). But having changing this to alphabetical is still preferable.

That’s obviously not only a fault of the Particle Web IDE, since this is not true for me on Windows 8.1/10 and Chrome v57.x - so I’d suspect your OS, browser version and screen resolution to play a role in that.

But in general your points are valid and I’m sure @stefanmoraru will be happy to have a look at your suggestions

2 Likes

@ScruffR, I agree @Michele on the font issue. I have always pointed this out since the IDE first appeared. Since neither the font or the column width can be adjusted, long filenames will spill over:

:slight_smile:

@Michele

Awesome feedback! Happy to hear that parts of the Web IDE worked as you wish, and I’m sure we can improve it in the future.

I will take note of the feedback you gave here. Will try to fix some of them in the near future.

1 Like

Hmm… I click on Ready. but nothing happens.

Thanks for the ^F/^G tip. Didn’t think of it. I guess while I often use ^C/^V, I like to use the menu items for find/replace.

Yea, sorry - was a bit shaky when I “double checked” - you actually need to click the icon next to it.

Which in fact also tells whether the last build

  • worked:
    or
  • didn’t:
1 Like

Your screen shot looks essentially like what I see, and I find it hard to read. I’m using a 26" Samsung DVI monitor running 1920x1200, Chrome 47.0 (it refuses to upgrade beyond that), Windows XP SP3. I guess that’s why it’s called a personal computer. I (should) get to make it look in a way that appeals to me.

Thanks for your time and for reading my rants.

You’re kidding. I have three file tabs and each of them takes a third of the panel width - I don’t know how long the file name needs to be to get truncated. It’s definetly more than spark-dallas-te. (16 char) while I can easily read DFRobotDFPlayerMini.cpp (23 char with plenty to go).

Granted, if I had loads more file tabs this would become an issue and tooltips would be a great asset.

Just for the sake of argument, I’d be rather stuck if I demanded to have a browser do all that fancy, nowadaysy stuff but insisted in keeping my EGA text only personal computer :wink:

I see. That works, until you edit the file and save it again. Then the prompt turns to “Ready.” with no icon to its right. If I walk away for a while to go grocery shopping, when I come home and look at it, I’m like, “Uh, what was the last thing I was doing here again?”

Perhaps a two line display would help. above the “Ready.” it could say the operation that came immediately before. It already says “Last Event”, why not also “Last command”? Like this:

Until you start adding and removing parentheses. I, at least, find it all too easy to accidentally lose one in the heat of a massive late-nite edit.

Would I kid you? :slight_smile: Here look:

[quote=“ScruffR, post:12, topic:31022”]
but insisted in keeping my EGA text only personal computer
[/quote]
Well it’s an Asus Intel Core 2 Duo at 3.16 GHz. Just because it’s old doesn’t mean it’s no good. But just for laughs, I tried it using Chrome 56.0 on my Raspberry Pi and sure enough, the fonts are all smaller there. You still can’t see the file extension in the tabs but at least it gets up to “spark-dallas-temp”. Then I tried changing the font size on the PC Chrome browser with Settings -> Advanced settings -> Web content -> Font size, from Medium to Small. That changed the font size everywhere - except the the Particle IDE.

So I guess from now on I’ll just edit my code on the Pi.

2 Likes

I’ve proposed a change for that which would cut it off (with ellipsis) and then show the full name in a tool-tip when you hover it. With a bit of luck @stefanmoraru can implement this some time soon :wink:

1 Like

@Michele, as others have noted, thank you for your feedback. As others have noted, some of those issues have workarounds while others are still awaiting improvement from the Particle team.

@stefanmoraru, who commented earlier in the thread, is one of the individuals who has been helping with changes and improvements to the Web IDE, so please know that your feedback is already finding the right sets of ears within the Particle team.

I’m hoping that we’ll be able to resolve some of those issues sooner than you expect while others might take us a bit longer to get too. Community feedback helps us know which issues to prioritize, however, so I hope you’ll continue to voice your experiences using our tools and suggestions for how we can improve them!

3 Likes

Glad to hear you’re on it, Particle remains a perfect environment for introducing students to IoT (and everyone we’ve demo’d Photons to has the same opinion – you seriously ought to consider getting a booth or putting on a vendor session at SIGCSE). My only gripe about the WebIDE is that is, AFAICT, no option for organizing files into folders – and after a semester, I tend to have a vast number of them. I know I can download them, but … this is IoT – they should be in the cloud.

1 Like

If I may add, Ctrl-G in Chrome (Windows) opens Chrome’s search box. It appears Ctrl-K is the right thing there (it usually doesn’t trigger Chrome’s search bar, but sometimes it does). Ctrl-H always ends up opening the history… that’s really not useful.

What would be nice is if, when you search for something, the IDE would simply highlight all instances of that search term in the current file (or offer that as a “sticky” option). It’d be a ton easier to use.

Or allow user preferences so we can remap things for ourselves.

Well how about that. I didn’t even know that. The other thing I don’t like about Chrome’s Find feature is that it just advances the cursor to the next instance found, it doesn’t highlight it. That can make it hard to find on a crowded page.

And I’d REALLY like a way to remap the editor’s text colors.

And fix the virtual tri-color LED in the lower-right corner. I unplugged my Photon last night and the editor still thinks it’s online. (If I refresh the page, it realizes it isn’t).