Build IDE Problems

In general, things are going well with my cores now, but last night I ran into a problem with the web based editor/compiler IDE. I had made some edits and was cutting and pasting to and from a local text editor when my project just stopped working: it would seemingly compile and flash to the core, but when run, nothing happened, no serial port, no flashing LEDs, etc.

I tried many debugging ideas including trying other apps on the core (which worked), adding lots of debugging Serial.print statements, a factory reset, etc. but nothing made sense. It was then I noticed a typo in my code that was NOT being reported as an error by the compiler. I started moving intentional syntax errors up through my code until I found that an error on line 1 was reported correctly, but line 2 and below were not being read and compiled. I tried deleting the white space between lines 1 and 2 and retyping some of it, but that didn’t work either.

I then did a select-all on my code, made a new project, and pasted my code back in. This new project then compiled and worked correctly!

I am sure this had something to do with me cutting and pasting from an external editor, but I think everybody should know that if the compiler is not reporting errors, that doesn’t imply things are all OK and new project is worth trying if things don’t make sense.

But did you get magenta flashing as the core was flashed?



Yes, all the steps of the flashing process seemed to work fine including magenta flashing and flashing green and breathing cyan. My theory is that only the first line of my code was being compiled, which was an assignment statement, and so none of my setup or loop code was running.

Thanks, a different problem to the one I have (and at least one other). For me the IDE claims to be flashing, but the core continues to breathe cyan. Yet a factory reset seems to re-flash Tinker with no issues (ie. lots of magenta flashing).

Thanks @bko for the report - would you be willing to share the code that was causing the issues? Would be great to help us debug the IDE.

1 Like

@PaulRB I’ve seen this as well, and (at least in my case) it’s always been that the Flash button is saying the code compiled and flashed OK, when in fact (if you just run Verify instead) there are one or more errors.

1 Like

Thanks @timb, that was it all right, I’ve posted the offending code on this thread in case its useful to @zach.


1 Like

I would be happy to share my code, hopefully privately for now. It works, but it is still a work in progress.

What’s the best way to get it to you? I can be reached at