[Solved] Core Reporting Suuccessfully flashed, but no magenta flashing witnessed

Hey Guys and Gals!

I am flashing my core over the web IDE, with the core selected in the cores dialog that matches with the coreid I got from “spark serial identify”.

It says it all goes well. Great.

BUT - the core never flashes magenta indicating it is being updated, and nor do the web calls I make to the core indicate my new code has been taken on.

Any ideas? I know the build system was having some issues, is this a hangover from this?



Is there a breathing cyan dot beside the core in the cores tab?

Hi, yes - indeed there is. The core itself is breathing normally and I can call it through the API, but it responds as I would expect the old code to respond.

Try flashing the new code again now :smile:

Tried multiple times again, no joy. Done factory reset and run a serial setup and re-running the flash, I get the same behaviour. I hit build, with the newly registered core selected in the IDE, it says it has flashed successfully - but no magenta flashing.

Not sure what avenues are left now.

Hi @mblackler

When the web IDE says “flashed successfully” it really means that it has sent the binary file to the cloud handler that sends it on to your core. There is no feedback from there back to the web IDE, so as soon as it sends it to the cloud software, it thinks it is done.

1 Like

Thanks @bko !

So what can typically stop the binary file being pushed from the cloud handler to the spark core? Can the size of the file stop it from getting pushed?



Factory reset the core and use serial to check the core id. Verify it against your account and connect it to wifi. Try flashing again after that

1 Like

Hey @kennethlimcp, I’ve done that, no joy.

Can this behavior indicate that the resulting binary was too big?

Do you have Spark-cli installed?

The Web IDE/ Spark-cli will compile and if the binary is too big there will be an error.

So i presume:

1.) The core id is correct

2.) You have managed to flash the core with firmware via OTA before

Can you flash the core with the default tinker firmware?

Using Spark-cli, spark flash CORE_NAME tinker

I do indeed have it installed.

The core id is correct and I have managed to flash the core with firmware via OTA before.

Flashing using tinker works. I then attempt to flash my project directly afterwards, no indications from the core that anything happened.



Are you using the WEB IDE for your project?

Try creating a new app with a blink .ino file and flash it

I’m piggy backing on here, because I’m having the same problem as @mblackler. I just followed the last suggestion of trying to flash the blink.ino file, and the cloud says it flashed successfully, but my core never flashes magenta, and is still breathing cyan.

I just got this one in the mail last night, but I have another one that has been a part of my home automation system for about 5 months. I never had these issues with it.

Can you perform a factory reset, get it back to breathing cyan and try flashing a blank app?

I figured out my problem. The Device ID in the web IDE was wrong, even though I had selected the correctly named core. I’m not sure how that could have happened, but it’s fixed now.

1 Like


Same issue for me… 1 byte differed from correct device ID. I never claimed “manually” core. It looks like a bug.

Hi lah,

Can you tell me more about the issue you’re seeing? Are you saying you claimed a different device?


Yes, that’s it! I got flash succcessful messages but core never blinked magenta. So I compared cloud device id and real core device id, 1 byte differed… it began with 55ff6d… but was instead 55ff6e


Can you try releasing that device, and re-claiming your device and flashing that?