Issues flashing Spark Core

I’m having issues trying to flash my Spark Core that I just got. I have the same issue via the web Spark Build and with Spark Dev. The core will flash magenta randomly for about 60 - 90 seconds then gives up. It seems to flash a lot starting out then progressively slow down. Once it gives up, it will go back to running the tinker app. The code I’m trying to flash is very basic, just turning digital outputs on/off. The cc3000_patch_version is 1.29. Any ideas what could be wrong?

That’s weird… try a factory reset?

I have tried that multiple times. Sometimes the core will completely stop working until I do a factory reset. There has also been a few times when it would flash the red SOS.

Have you ever been able to flash code via web ide?

If you have Spark-cli or DFU-util installed, we xan try to resolve this.

I have tried with the web IDE as well and I experience the same issue. I’ve started going down the path of getting Spark-cli installed. I have node.js, openssl, vc-redist, and dfu-util installed, but I can’t figure out how to get Spark-cli installed. It looks to be getting a bunch of errors. Do I need to download Spark-cli and put it somewhere? Here is the output of doing the install.

Your environment has been set up for using Node.js 0.12.0 (ia32) and npm.

C:\Users\AshleyHarrier>npm install -g spark-cli
npm ERR! Windows_NT 6.1.7601
npm ERR! argv "C:\\Program Files (x86)\\nodejs\\\\node.exe" "C:\\Program Files (
x86)\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-g" "spark-cli"
npm ERR! node v0.12.0
npm ERR! npm  v2.5.1
npm ERR! path C:\Users\AshleyHarrier\AppData\Roaming\npm\node_modules\spark-cli
npm ERR! code EISGIT

npm ERR! git Appears to be a git repo or submodule.
npm ERR! git     C:\Users\AshleyHarrier\AppData\Roaming\npm\node_modules\spark-c
npm ERR! git Refusing to remove it. Update manually,
npm ERR! git or move it out of the way first.

npm ERR! Please include the following file with any support request:
npm ERR!     C:\Users\AshleyHarrier\npm-debug.log


Looks like git is not playing nice somehow.

Is it your first time ininstalling Spark-cli?

delete c:\users\ashleyharrier\appdata\roaming\npm\node_modules\spark_cli and then try npm install -g spark-cli again.

This is the first time installing it, but I might have put the files from GitHub into that location manually trying to get it to work. So I deleted c:\users\ashleyharrier\appdata\roaming\npm\node_modules\spark_cli and tried again. I noticed it couldn’t find Python so I then installed that. Now I’m getting a bunch of other errors.

Your environment has been set up for using Node.js 0.12.0 (ia32) and npm.

C:\Users\AshleyHarrier>npm install -g spark-cli
> serialport@1.4.5 install C:\Users\AshleyHarrier\AppData\Roaming\npm\node_modul
> node-pre-gyp install --fallback-to-build

child_process: customFds option is deprecated, use stdio instead.

erialport>node "C:\Program Files (x86)\nodejs\node_modules\npm\bin\node-gyp-bin\
\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild --name=serialport --config
uration=Release --module_name=serialport --version=1.4.5 --major=1 --minor=4 --p
atch=5 --runtime=node --node_abi=node-v14 --platform=win32 --target_platform=win
32 --arch=ia32 --target_arch=ia32 --module_main=./serialport --host=https://node --module_path=C:\Users\AshleyHarrier\AppData\Roami
lease\node-v14-win32-ia32 --remote_path=./serialport/v1.4.5/Release/ --package_n
ame=node-v14-win32-ia32.tar.gz --staged_tarball=build\stage\serialport\v1.4.5\Re
lease\node-v14-win32-ia32.tar.gz --hosted_path= --hosted_tarball=https://node-serialport.s3.a
child_process: customFds option is deprecated, use stdio instead.
Building the projects in this solution one at a time. To enable parallel build,
please add the "/m" switch.
..\src\serialport.cpp(75): warning C4344: behavior change: use of explicit temp
late arguments results in call to 'v8::Local NanNew(char *
)' [C:\Users\AshleyHarrier\AppData\Roaming\npm\node_modules\spark-cli\node_modu
          but the regular function 'v8::Local NanNew(const char *,int)' is a
   better match
          if you expect 'v8::Local NanNew(const char *,int)' to be called th
  en you need to make it an explicit specialization

... (There are a bunch more errors like this)

@MotoX244, can you scroll downwards and check if they mentioned a serialport error?

Ah, i missed the errors. Here they are.

..\src\serialport_win.cpp(254): error C2039: 'New' : is not a member of 'v8::St
ring' [C:\Users\AshleyHarrier\AppData\Roaming\npm\node_modules\spark-cli\node_m
          C:\Users\AshleyHarrier\.node-gyp\0.12.0\deps\v8\include\v8.h(1599) :
  see declaration of 'v8::String'
..\src\serialport_win.cpp(254): error C3861: 'New': identifier not found [C:\Us
gyp ERR! build error

I just tried flashing it from work, with the core at home, and it worked. When it was failing I was at home on the same network as the core. Seems strange that would make a difference. I’ll have to try again when I get home tonight.

1 Like

I tried flashing it again from home(same network) but it wouldn’t work. I would prefer the web method of updating in the future if I can get it to work. I plan on putting the cores inside enclosures in the future.

I have a similar problem to @MotoX244 every so often.

I mainly use the web app to push code to the spark and it did looks like its flashing like it does any other day except it doesnt flash at all.

Ive tried factory resets, Ive tried basic example code to see if maybe its a bad piece of code blocking the flashing.

But it doesnt seem like anything I do makes a difference when it locks up like this.

Is there anything that can be done to figure out why its not flashing?

My main issue is I have one out in the field at the moment and Im looking to put up a few more. If this happens while they in use it will make supporting them really difficult