How do I completely reset a core and start over?

I’ve been struggling to revive an old spark core that worked fine the last time I used it several months ago. It had connected fine over my wifi to the spark cloud. And I also had it working fine on a local cloud. Now it won’t connect to anything. After trying everything I could find on line, I decided to start over and reset it back to connecting to the spark cloud. But I can’t get it to connect. My wifi has not changed and I’ve rechecked all credentials multiple times.

I have done factory resets (MODE + RST tap til flashing white), and wifi resets (MODE til rapid blue flash). I have tried iPhone app setup but get only blue flashing and “no cores found”. I have tried USB setup via linux screen to enter SSID + WPA2 + pw. It says it loads but the spark then flashes green, then cyan, then red (3 times) and repeats. I can see the <core_id> using spark identify when in listening mode. I have tried using sudo spark keys doctor core_id when in DFU mode, which seems to work except I get “submitPublicKey got error: Permission Denied” when it gets to uploading the new public keys to the cloud. I then used spark keys send <core_id> <core_id>, which says “submitting public key succeeded!”. But it just flashes blue and won’t connect.

I suspect a keys problem, or a corruption of some kind. How can I complete reset the core and start fresh? Do I need to also clear out anything on my cloud account as well?

Thanks for any help…

Can you shoot an email to if you haven’t already? I’d like to take a look at what’s going on in the backend and I need you Core ID to that (and I don’t want you posting that publicly)

Thanks for the quick response! I’ve sent my Core ID as requested. Let me know what I can do to help troubleshoot from here.

Check and make sure you have logged in on spark cli. You should see the core listed using spark list :slight_smile:

The core is listed when I use spark list and shows it is offline. But I cannot connect to it.

Is the core running the default tinker firmware? Maybe we need to check the backend as well.

@dave something for you ?

This is why I was having him email I’ll ask Dave to check the backend tomorrow or the next time he’s free

1 Like

@kennethlimcp. I did a factory reset. Doesn’t that reinstall Tinker? She since I can’t connect to it I can’t confirm what is loaded. Is there a way to check this via spark cli?

Having the same issue - been a while since I worked on my core and there’s no connecting to my device. Had claimed it before, now can’t communicate.

I’ve done factory reset, verified WiFi pw… Any clues?

What happens when you guys attempt to claim it?

I can’t get to the connected to the cloud point (breathing cyan) so I can’t attempt to claim it.

You don’t need to re-claim it. If you’ve ever claimed it with the Spark cloud it will stay claimed until you explicitly unclaim it
I saw your ticket. I’m having dave look at it when he gets a chance

Any new thoughts on this issue? Has anyone been able to have a look at the back-end? Is there any way to wipe the cloud records for this core so it would be like factory fresh? I seem to be locked out of at least some functions on the cloud with my own core. I get as far as variably flashing cyan (~4 Hz or faster) but it never actually connects to the cloud (breathing cyan). I tried releasing it (spark core remove my_core_ID) and got “Didn’t remove the core Permission Denied”. This after successfully logging in to my account in CLI.

Hi @timeless

This is problem that can best be solved by email at rather than here in the forum.

1 Like