How can I add my Argon to an existing Particle network?


#1

I changed WIFI network, and instead of adding the new network via CLI I stupidly unclaimed the device and tried to re-add it through the phone app. Now I have an existing network on my Particle Console that I don’t seem to be able to connect to. I tried using the same name in the Particle setup mobile app, but it didn’t work. Do I have to add a new network with a different name in order to add my Argon? The Argon is visible on the device list in the console.
Given the 10 network limit stated by Particle, I’m keen to re-use the existing one.


#2

What is a Particle network?
If you mean an existing mesh, then yes, you can via CLI (see particle mesh --help).
But, while the idea was that any gateway capable device which joins a micro network that doesn’t currently have a gateway assigned to it would be promoted to become the new gateway automatically. As it turns out that feature doesn’t (currently) work as intended.
See this thread

That limit only means 10 concurrent, current networks. Once you remove all devices from an existing network the network will disappear and your 10-network-quota will get that one now free instance back.


#3

@pierrep definitely check out with @ScruffR is saying about this. I ran into the same troubles starting out. The phone app won’t let you “re-use” the networks that you’ve created. Just like he mentioned, you can use the CLI though!

Looks something like this:

particle mesh add <your argon ID/name> <name of device on the network you want to re-join>

You can make it go faster too if you use the --password and add your mesh network password to the command as well. These CLI commands are awesome and I’m not looking back after that!


#4

Thanks, I’m going to try the CLI option now, that looks like that will answer my question.

I have another strange thing though - my network didn’t disappear even when I unclaimed all my devices…see the screenshots.


#5

Great, thanks! Yes this is what I was looking for!


#6

This happened to me as well. Did you un-claim a device before removing it from a network? I unclaimed a boron and the network persists with 0 devices.

Alternatively, it takes a bit to disappear from what I remember. Wait a day?


#7

Yes I think I unclaimed the device first. It’s been several days already…I just assumed it would clean up after itself, might be a bug.


#8

@rickkas7 is there any way to file a bug for the web console?


#9

Unclaiming a device is rarely helpful when you want to keep the device.
Unclaiming is (mostly) meant for devices that you want to pass on to someone else.

IIRC it wouldn’t be forbidden to have a device from one user participate in another user’s mesh network, hence kicking it off the network without it being reassigned to another network would be counterproductive in this scenario.

To solve the problem, reclaim the device, assign it to another network and then it should disappear.
If that doesn’t help file a support ticket at support.particle.io