High School Robotics Course using the Particle.io Mesh Devices Blog


#21

I started writing this blog at a different spot. Oops.

So a student showed me an easy way to login to our school network, without the normal user and password.:grinning:

So I got an Argon working as the network gateway and am attaching Xenons to it. The setup for Xenons is a bit faster than for Argons, seems to be only a 1 part installation.

The Ethernet Featherwing is a bit faster than using the Mesh connection but not by much about 5 minutes to do the software upgrade with the Featherwing and perhaps 8 minutes with the Mesh connection. One real positive is I am doing this during class time (all with 1400 students on the internet instead of learning :roll_eyes: ) something I could never do with the Photon.

When setup properly the Xenons seem much more stable than my first attempts. 3 Xenons and 1 Argon Mesh seem to be working nicely.

Reset a Xenon and it took about 10 seconds to reconnect to the mesh.

Reset the Argon and the entire mesh dies. Took about 1 minute for the Argon to reconnect, remember I am on a very busy Wifi network. Unfortunately the Xenons are not smoothly reconnecting. Flashing green. unplug and plug in the Xenons, no improvement.

Unplug and plug in the Argon wait till it breaths cyan, then unplug and plug in the Xenons one at a time. Xenons reconnect very quickly.

That is interesting, I may have to redo that again.

This time I pulled the plug on the Argon. The other devices stayed breathing cyan. I am not sure if they are connected or simply don’t know that the Mesh gateway is dead. However this time everything rebooted very smoothly when I plugged the Argon back into power, as soon as I plugged in the Argon the Xenons detected that the network was down and reset on their own properly.

Lets reset the Argon again instead of pulling the plug. This is where it has some issues. The Argon resets fine, the Xenons know the Mesh has died and search for it flashing green but the Xenons do not reset even after they have been unplugged and plugged back in. The key to the whole issue is that the Argon must be physically unplugged and plugged back in not just reset before the Xenons will reboot.

Third try. I reset the Argon, it reboots but the Xenons dont reset to the mesh. I unplug the Argon and plug it back in. Now the Xenons reset fine without being touched.

Forth attempt as above except one Xenon has a hard time re-attaching to the mesh. Pull its plug and it reboots fine.

The fun continues.

So I have my 1 Argon and 3 Xenons working at school. I load my simple blink program on a Xenon. The targeted Xenon device flashes pink properly and all the Xenon devices reset properly, but the code does not work.

I think it might be my Photon code so I load Blink-an-LED from particle. Try another Xenon and the same thing. This time I try the Argon and not only does it not blink but same as the above post, the mesh devices do not reconnect until the Argon is unplugged and plugged in.

Also the Argon D7 never blinked. Any idea what is happening here…anyone…

I might connect an Argon without the Mesh and see if it works with the blink program

I just loaded up my trusty photon to check if the LED blink program actually worked and connected in seconds flashed and was blinking fine in about 9 seconds. So I guess I will try an Argon off-mesh and see if it works better.

Thanks @RWB, @cyclin_al and @jtmoderate876 for the replies, kind of feels like we are lone, unpaid, beta testers at the moment. Well actually we are a small group of unpaid beta testers.

Knowing the device works prompted me to look deeper. I tried an Argon off-Mesh and it still didn’t work but then looked at the firmware and noticed this

default

The default setup is not what was on my device. I think with the photon whenever that happened it would flash the new firmware, but I guess at the moment the Mesh devices don’t auto detect and update the firmware.

Anyway. Happy story my Argon works!

Next. Mesh.publish anyone got a simple program that allows each mesh device to brodcast some information that flashes D7 a distinct number of times. So as I watch my devices and add or subtract Xenons I can see if the Mesh knows they are there or gone.

I just saw today that rc.26 has gone. The old method to increase a version was to select the version and install an .ino. (Careful you couldn’t go back to an old version without a full factory reset, not sure if that has changed) If your photon was at the top of the list (default) then every time you installed an .ino the Photon would update if needed. This was a huge problem with bad Wifi, so I would often pick a version and have my class set every photon to that version, then if a new version came out I would test it, switch briefly to default update every photon and then switch to that version instead of default. Only because of bad wifi. The Argon seems to handle my school wifi better than the Photon so that might not be a problem now.

So Last night I tried to setup my 1 Argon and 3 Xenon network and I got the Argon working but the 3 Xenon’s just flashed green. This morning I tried again with the Argon which worked, but the xenons didn’t (just flashed green). I updated and installed a 4th Xenon and not really sure when but the old Xenons started working. Briefly I had all 4 Xenons breathing cyan.

About 5 minutes later all my Xenons are flashing cyan which I think means they have lost the Mesh, Argon stable. Will leave things for a while and see what happens.

Note: Not having much luck with adding multiple Xenons to one Argon with the app, after adding a Xenons it says do you want to add another. This has not worked well for me. If you have an issue it kicks you out of the add another so I have resigned myself to add each xenon individually.

P.S. I would be great if the app allowed multiple steps. On step to update a device, another step to assign Wifi and another step to Add Mesh devices to a mesh network. I am always starting from scratch, have entered my home Wifi password multiple times. Also since most laptops have Bluetooth it would be nice if there was a web or windows desktop app to do all this installing. I seem to remember some kind of web softapp for the photon.


#22

People need to have a look at this page https://community.particle.io/u?period=all and click on the heading titles. To put things into perspective I started with the Spark Core about 4 years ago and only have 253 Likes. Check out these other forum users.

@ScruffR 8,900 Likes
@peekay123 6,000 Likes
@rickkas7 4,000 Likes (Actually employed by Particle)
@bko 3,700 Likes
@Moors7 3,300 Likes
@kennethlimcp 3,000 Likes
@BDub 2,900 Likes (Another one actually employed by Particle)

The list has 37 users before you get to my level. This community and some great hardware is what makes the Particle product so impressive. Just thought I would send a shout-out to all the helpers out there.

All 4 of my Xenons have crashed again, so I can’t test out any Mesh networking until Particle allows us to add Argons to a network like was mentioned in this post Help Understanding Mesh Network Pricing After Free Gateways Are Used Up?

On a positive note: The Parent Advisory Committee at my school (the PAC) just gave me money to make 8 RC and Wifi (Photon or Argon) Self driving and Wifi controlled cars. Teacher’s your PAC is a huge resource if you follow their rules. I can’t use the cars for teaching but can use them in a club!

I made a test version a few years ago with this failed kickstarter . Recently my students and I solved the time lag issue with a websocket. We got the Particle Cloud time lag of about 1200 ms down to 7 ms using a websocket the video is here github for websocket here

Just arrived 1 of the 8 RC Cars . This is an RC Pro Shredder a fair bit cheaper than Traxxas Cars.


#23

I have done a few other posts

and also

So I think that I have done all I can here until Particle fixes the Xenon connection issues and allows Developers to add multiple Argons to a mesh (So important to give a Mesh some redundancy, presently if your only Argon dies your entire mesh becomes useless). (Can someone tweet @rocksetta if these changes happen any time soon.)

Might as well go back to Machine Learning, Neural Networks and Artificial Intelligence since it is less frustrating. Anyone else interested in combining AI with Particle products might want to check out my Deep Learning site at https://www.rocksetta.com/tensorflowjs/

An exampe of some AI that I am working on is here, for which a webcam can detect human faces https://hpssjellis.github.io/face-api.js-for-beginners/


#24

I am not really very good at giving up. :smirk:

I tried the Ethernet Featherwing at home and realized that it was not being used at all for installing the OS update that was all from my phone using Wfif and Bluetooth. However the Featherwing worked great at home. The Xenon connected to it and was very stable.

However at home the mesh stuff was not very good. Worked a bit better but did not last more than about 10 seconds of connectivity.

At school a different story. The Ehternet Featherwing does not work. The internet connectivity is a bit more complex, However, VERY STRANGE: Everything works fine at school!

I can connect the Argon to Wifi, I can connect several Xenons to the Argon. If I disconnect the Argon all the Xenons stay connected (AND COMMUNICATE WITH EACH OTHER WITHOUT THE ARGON!). I can reset a Xenon and it will reconnect without shutting down the other devices.

I can go mobile with the Xenons, each Xenon about 25 meters from the other for a total distance down the halls of about 75 meters using 3 Xenons.

Looking good from school, not so good from home.

Really good Mesh Hello World code at


Mesh Hello World
#25

I finally got my pre-order batch. I think i need to re-flash my PartiBadge (slow-blinking blue mode LED, never gets to breathing -cyan nor fast-blink green), but my other in the ether-dock is breathing cyan just fine.

Now time to see if my sketch can get status of the mesh, and any idea of the mesh map from the hardware.


#26

Made a new topic here


#27

Still testing connection distances with the mesh devices. Here is what the students did today. We can’t just walk the 60 m outside and expect the outside Xenon to get a connection with my Argon in the window, but we could use several Xenons at 25 m intervals inside to get the outside Xenon to have a good connection. Then once it was connected we could remove the intermediate Xenons and the connection continued.

inside-outside

On another day we managed to have a student walk much farther than the field distance (> 100 m) away from the Argon, but in that situation the Argon was outside.

I would expect much better results with more Argons and Xenons working together.

Good point @RWB. This was with the default Xenons no antennas attached.

We were then going to use another Xenon and walk away from the repeater Xenon but that person did not get too far. Even though this is outside there is a fair bit of buildings around. Will do more tests when I find more cell phone chargers to power the Xenons.


#28

This is without antennas connected to the Xenon’s right?


#29

So much rides on obstructions. The Xbee 900 products use a lower (915MHz) frequency which has much better penetration. Newer mesh products use 2.4GHz which is more susceptible to obstructions and interference from other devices in the same band. This is why WiFi meshed routers are becoming popular since WiFi signals suffer the same fate. It will be interesting to see the range with rc26 (which boosts the output by +8dBm) coupled with an external antenna.


#30

Big surprise. I just flashed some code to the Xenon which seemed to stop it from connecting to my Mesh. Was about to put it in safe mode (tap RESET while holding MODE until it flashes purple about 3 seconds) then I thought that it will not work becasue the Xenon does not have Wifi. Tried it anyway and it worked fine, was able to flash some better code and back to breathing Cyan. Weird but cool.


#31

I have said before that my Ethernet Feathwing did not work at school but was rock solid at home. Today I made some code that would show Ehternet IP information. Super excited to get home and try it and guess what… My Featherwing does not seem to work anymore at home.:disappointed:

I noticed a pre-release 0.8.0-rc.26 that I don’t have installed might be the problem,that brings up another point …

How do we find out if the cloud firmware has been updated. Found this link which is 4 years old and not relevant anymore

Or is the cloud updated at the same time as the device firmware?


#32

On another issue I found this which explains some of the issues I am seeing

Continuing the discussion from [Updated 12/10] Particle Mesh Known Issues and Fixes:


#33

What do you mean with cloud firmware?


#34

Just wondering if particle ever updates how the particle cloud deals with connections to the devices?


#35

Hey @ScruffR what about this statement in the releases

IMPORTANT: Argon NCP firmware needs to be updated to v0.0.5 after updating to 0.8.0-rc.25-mesh. The release binaries can be found here

Is that something that gets auto-installed or is that something users have to install manually on the devices. Just a bit confused.


#36

Do you mean on the devices then that would be the Device OS or if you mean on their servers then it would not be firmware but software.

With the Safe Mode Healer I’d expect it to be delivered automatically too, but doing it manually is no big deal either.
BTW, if you already had 0.8.0-rc.25 you already have the NCP 0.0.5 on your device.
The NCP update is also one of the things that get flashed via the mobile app. When you setup your Argon and the app starts uploading an update to the devices the NCP update is the smaller of the two updates.


#37

Software. Where is the github for the cloud software and the version numbers?

Reason for my question is that my featherwing worked great at home 2 days ago, not it is almost useless, just wondering if particle has changed something, since my device firmware has not changed.


#38

The corporate cloud software is not open source - I think.

But there may be other factors more likely why your ethernet is not working anymore.
Have you set the device up to detect the Ethernet FeatherWing? This is not on by default.
Are you using the Particle Ethernet FeatherWing or the Adafruit one?


#39

Thanks @ScruffR that makes sense.

This would be a great place for to tell us of the cloud version

https://status.particle.io/


#40

I thougth the Particle Ethernet Featherwing did auto detect, seemed to a few days ago. I thought that was the point of the board.

you know. on the system status page it does say that mobile customers are having maintenance done. That could somehow be the problem. I will wait a while and try again.