Help.. photon program Not running?

Hello guys,
Need your help with the following.
I have project that the last time I play with it was on June, the only build target that at that time didn’t throw me any errors was the 0.6.1-rc.1 . It’s a modbus master , + mqtt and couple functions, + adafruit pixel lib.
The project worked ok in a demo rig … till today I decided to make some changes… and when I tried to flash the photon using the build target 0.6.1-rc.1 when i do that it read that message below

So I decided to try a different build that do not give me any error, I found out that the only one that work is the build 0.6.0
So i flashed the photon with that version and now my program that used to work fine on photon … do nothing… how that is possible ?
What is required to be done to get the program compiled and flashed ok?
I Have several functions on that program that I quickly used to see those registered on the console… now nothing appear… is like the photon is not running any program? please any advice any ideas?
I don’t want to start messing my program that work fine for several months.

I use Particle Desktop IDE v1.18.0

I tried also latest build that gave this error on the Mqtt.cpp

commented out that line of the error and the program compiled Ok, tried to flash photon… but same behavior… photon program seems not to be running…
thanks for any help

the problem seems to be with the Desktop IDE (Dev), I have uninstalled then installed again… but I have the same problem… the IDE (DEV) is seems is not doing what suppose to do
what else is required to be updated on windows? c

Let me ping someone that might be able to help, @rickkas7 are you able to assist?


I have 2 computer where desktop IDE(dev) is installed and work fine 3 months ago… and now both have the same exact problem, program compile and flash ok, but its like the code is not running on photon…
yesterday I moved the code to the web IDE, compiled and upload the program to photon and that way it just work fine.
So the problem is with the desktop IDE, but I am not sure what its exactly happening.

Hello guys,
I just found the problem.
Since the beginning that I started to play with Particle Desktop IDE I use to have
project directory/ SRC folder with all .h and .cpp files and one additional folder that have .ino file, and that way worked fine form me for months .
Now it seems that way dint work anymore , So I was reading the particle IDE documentation and read this:
All the files have to be on the same level (no subdirectories) likethis
So I decided to re arrange my project and put all the files in one folder and now it flashed the photon OK.