Flash Unsuccessful

After adding new photon, i see “flash unsuccessful”
device is claimed, online and selected, code compiles and is runs ok on other devices.
andy ideas?

extra info:
simple code also will not flash
when i try recovery mode shows up as cyan, not magenta on the IDE and still wont flash.

Similar issue, I’m getting this error, even with a ‘blank’ app:

void setup() {

void loop() {

Error: Could not compile. Please review your code.

@andyg & @jasoncoon, what system version (and device) were you targeting and does the issue still exist?

There was an outage for the build box for 0.6.0-rc.2 earlier today but that should be history now.

1 Like

I’m using Particle Build in Chrome, Photon, Default firmware version (0.5.3). When I try to Verify even a new empty app, I get “Error: Could not compile. Please review your code.”. Same error for any other app. No other details, error message, line number, etc. I’ve tried refreshing the browser, restarting my PC, etc. I’ve contact support, will update here if/when I get a response.

Good morning,
I am using 0.6.0-rc2 when i switch to default (0.5.3), empty code builds and flashes fine.
upon switching back to rc2 i get the following error still with empty code.
Error: 500. Please try again later. If the issue persists, please report to hello@particle.io.
it seems that the cloud IDE is not communicating with the server consistently, e.g. devices show online (cyan dot) even when powered down (> 5 mins) tried 2 browsers with same result.
CLI seems to work as expected

Hi @andyg,
do you have a DMX-output as well? OR are you just using ArtNet to control the Photon and connected peripherals?


Hi @joky, still in R&D, but due to release some LED fixtures and LED drivers with ArtNet.

it would be great if you can release the dmx-output class under opensource :innocent:

hi, any ideas on this, things are better, but I still have protons showing being online when they are powered down for more than a day?

@andyg I’m facing a similar problem, even an empty code throws “Flash unsuccessful” error , but it does compile, ping and test signal correctly , I tried different firmware versions … were you able to solve the issue ?

Hi, it’s a long time ago but as far as I can remember, there was a problem with the web IDE that was resolved by particle soon after. I have not has this problem since. What firmware version is on your device?