Problems compiling (online IDE)

For some reason, I can’t get even the simplest code to compile and flash to my device (new Photon, just brought online a few minutes ago).

int led=D7;
void setup() {
    pinMode(led, OUTPUT);
}

void loop() {
    digitalWrite(led, HIGH);
    delay(500);
    digitalWrite(led, LOW);
    delay(500);
}
</pre></code>

When I try to Verify this, I get "Error: Could not compile. Please review your code."

So I tried grabbing the Example code for "Blink an LED", which looks like this (comments removed):
<code><pre>
int led1 = D0; 
int led2 = D7; 

void setup() {
  pinMode(led1, OUTPUT);
  pinMode(led2, OUTPUT);
}

void loop() {
  digitalWrite(led1, HIGH);
  digitalWrite(led2, HIGH);
  delay(1000);
  digitalWrite(led1, LOW);
  digitalWrite(led2, LOW);
  delay(1000);
}

It also says “Error: Could not compile. Please review your code.”

When I try to flash either of them, all I get is “Flash unsuccessful.” No other information provided.
My device is online and “breathing cyan”

1 Like

Same here, even with empty skeleton code. I found suggestions to restart the browser and logout/login Build, but they haven’t helped so far. Trying with another browser. If that does not help, then they have a problem with their build farm, despite the full green status pages.

1 Like

Same issue here - a simple fork of the blink program will not compile. My photon is also breathing magenta.

1 Like

Howdy!

Been developing today using Particle Dev on a MacPro for a few hours, and everything was going swimmingly.

Then, about 20 minutes ago, I started getting the “Compiler timed out or encountered an error” message at the bottom of the window. I’ve tried restarting Particle Dev, rolling back the changes I made, but still get the error. The status pages shows everything is cool, but I’m not sure where to look for possible problems because the error message is so vague.

Any suggestions? Help, as always, is greatly appreciated.

Cheers,
L3

1 Like

Old post on such a problem

I’ve just tried in vanilla Firefox, exactly the same as in Chrome. So the problem is not here, possibly.

Build is also superslow. I’m on a 100/100Mbps connection and everything else work fine.

Why do they have a full green status page with ~50ms response time statistics?

It is definitely not working.

Where can we report a system outage what they don’t see with their monitoring?

I started experiencing the same issue about 10 min ago.

Same here with even a blank sketch.

Output returned from “binaries”:

{
  "ok": false,
  "code": 200,
  "app_id": "55b55a7030b881dbc3000844",
  "output": "App code was invalid",
  "errors": [
    null
  ],
  "sizeInfo": null,
  "modules": null
}

I’ve just clicked Support above and submitted a support request referring to this thread. Hope they will help.

1 Like

+1 with compile issues with code that was fine just minutes ago.

Happening on both web and desktop IDE’s.

I bet there is an issue with system state not reflected yet on the status.particle.io page.

Ah well, time to go out for a walk anyways.

Their build farm must have a problem which is not reflected on the status page.

Hey guys,

Some of the elites have noticed these problems as well. We’re currently looking for ways to resolve this. I’ve opened a new topic on this here:

Hello Guys
I’m trying to compile my code on the Web IDE or on the Particle Dev but it is giving me this error:
Error: Could not compile. Please review your code
Any one has the same issue?
I also tried to compile another code but the issue is the same, so I believe it is something happening with the Cloud.
Thanks in advance
@ScruffR @Dave @bko @kennethlimcp

See pinned topic, it is a known issue right now.

1 Like

Hi, y’all. Sorry about that, we’re looking into this right now.

1 Like