Help needed with development problems


#1

Hi,
I am having unexpected issues with my Argon & Boron units:

Issues:
    • Particle Workbench
         a. Login to Workbench (ref) :white_check_mark:
         b. Flash & Debug Device
    • Particle WebIDE
         a. Flash & Debug Device :white_check_mark:
         b. Signal Device :white_check_mark:
    • Particle CLI
         a. Flash Tinker firmware :white_check_mark:
    • Particle IOS App
         a. Signal Device :white_check_mark:
    • Redbear Duo
         a. Getting Started (WebIDE/Arduino)

All six Mesh items listed above have worked previously, I am unsure what happened to instigate these issues. I currently observe the following successful operations:

Working:
    • Particle WebIDE
           a. Successful flashes currently observed intermittently, unsure why
    • Particle IOS App
           a. Successful setup of devices
    • Redbear
           a. Connection to my access point (Duo)
           a. BLE_Peripheral app (Nano, see results)

I am unsure what has instigated these and am eager to get back running, your help would be much appreciated let me know if possible!

Thanks,
Justin


#2

So you’re having issues. Would you mind telling us what exactly the issues are :speak_no_evil:? Errors, screenshots, problem descriptions, anything other than “this isn’t working” would be most helpful :wink:


#3

Certainly, see the ‘ref’ above for Workbench.a -

Problem

I will post another in further detail shortly. Lots of stuff here, wanted to start clean! :hushed:


#4

Here are some of the observed problems, as requested:

Particle CLI (a. Flash Tinker firmware)

  1. Plug in device
  2. ‘particle flash tinker’
  3. “Flash device failed: EPERM: operation not permitted, scandir ‘C:\WINDOWS\system32\LogFiles\WMI\RtBackup’”

Particle IOS App (a. Signal Device)

  1. Plug in device
  2. Removed from ‘Your Devices’
  3. Setup as new device
  4. More Actions -> ‘Signal for 10 sec’
  5. Works correctly, but only first time

Particle WebIDE (b. Signal Device)

  1. Plug in device
  2. WebIDE -> ‘Add new Device’
  3. ‘SIGNALING’ unsuccessful

Let me know your thoughts :pray:


#5

It’s almost always a bad idea to run 3rd party stuff from C:\WINDOWS\systeme32. It’s a system directory that prohibits certain actions (even for admin users unless admin privs are explicitly requested).
Hence it’s best to change into a user writable directory to perform these tasks (I think to remember having said that a while ago already in an other post to you :wink: )

What browser are you using?
Is the device breathing cyan at the time?
Is it still running tinker (or any other responsive application)?
Have you tried clearing the Web IDE cache?
Have you tried a different network to try signalling from/to?


#6

Hi,
I have made progress with my Argon, sharing an update see below. My Boron will not enter listening mode and is stuck in flash green blinking, unsure how to correct.

Particle Workbench (b. Flash & Debug Device)

Does not work, see below -

Flash results
> Executing task: make -f 'C:\Users\justi\.particle\toolchains\buildscripts\1.5.0\Makefile' flash-all -s <

  /cygdrive/c/Users/justi/.particle/toolchains/deviceOS/1.2.0-beta.1/firmware-1.2.0-beta.1/modules/argon/system-part1/makefile /cygdrive/c/Users/justi/.particle/toolchains/deviceOS/1.2.0-beta.1/firm
ware-1.2.0-beta.1/modules/argon/user-part/makefile
   text    data     bss     dec     hex filename
 651156    2152   65824  719132   af91c ../../../build/target/system-part1/platform-12-m/system-part1.elf
Serial device PARTICLE_SERIAL_DEV : not available
Flashing using dfu:
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

No DFU capable USB device available
make[2]: *** [../../../build/module.mk:129: program-dfu] Error 74
make[1]: *** [makefile:86: /cygdrive/c/Users/justi/.particle/toolchains/deviceOS/1.2.0-beta.1/firmware-1.2.0-beta.1/modules/argon/system-part1/makefile] Error 2
make: *** [C:\Users\justi\.particle\toolchains\buildscripts\1.5.0\Makefile:62: flash-all] Error 2
The terminal process terminated with exit code: 2

Press any key to close the terminal

Particle WebIDE (a. Flash & Debug Device)

Works correctly now, once I had downloaded tinker firmware

Particle WebIDE (b. Signal Device)

Works correctly with tinker firmware (was that required? lol, oops…)

Particle CLI (a. Flash Tinker firmware)

Yes running from a system directory is silly but that wasn’t the issue, CLI had installed to “AppData”! I moved this install to “C:\Program Files\Particle” next, now it works :slight_smile:

CLI Results

Install Ref

png

Move Ref

CLI%20Response

Cool! I still have the following opens:

Opens

  • Boron flash
  • Particle Workbench flashing
  • Redbear Duo

Your help has been greatly appreciated here, thank you guys much for your time! Let me know your thoughts, looking forward to getting these all up

Thanks!


#7

Was the device in DFU Mode at the time? That’s required.
Check in Device Manager what driver is used for the device in DFU Mode.

Nope, Tinker is not required - BUT your custom firmware mustnot prevent the system from servicing the background cloud task from doing its job in a timely manner.

When switching platform you (currently) need to run one of these
image


BTW, instead of posting several links to dropbox you can - and should - embed your logs and screenshots in the post.
If it’s only supplemental you can wrap the respective portion in a block like this

  <details>
  <summary>your desired title for the details block</summary>

  here follows your details block potentially with code/output blocks
  ```text
  this would be a plain text block
  ```  (no extra characters on this line allowed)

  </details>

This would then come out like this

your desired title for the details block

here follows your details block potentially with code/output blocks

this would be a plain text block

#8

Flashing now works, thank you!

Flashing Procedure:
Place device to DFU mode using reference [1]

//Boron Steps
  1. All closed & unplugged
  2. Open vs code
  3. Create new Project ('Boron-Test')
  4. Populate with WebIDE's 'Blink an LED'
  5. Select OS (deviceOS@1.2.0-beta.1)
  6. Select Platform (boron)
  7. Select Device ID (JMR-Boron)
  8. Clean (17s)
  9. Compile Local (2m18s)
  10. Breakpoints to both sketch routines
  11. Plug in, to DFU
  12. Flash Local (1m15s)	

Reference

  1. Particle Tutorials - Workbench
    “In order to use the Flash options, the device must be connected by USB and in DFU mode (blinking yellow)”

Debugging is not working successfully, see below -

Debugging Response: OpenOCD is not opening successfully.

Thoughts?


#9

Have you seen this post?

It should even be pinned for you till you read it :wink:


#10

Interesting, I tried this today and it was not successful -

Revert Cortex-Debug Procedure
//Procedure
1. Open Cortex-Debug extension
2. Disable automatic updates
3. Install version v0.2.3
4. Reload Workbench
5. Begin Debug (F5)
6. Begin Terminates (Error Code 2)  <- Same result

I had not expected ‘Hello World’ for Workbench to take this much time and include these unexpected errata, my apologies for not reviewing the forum first.

Let me know your thoughts, thank you for your help here.